Can't see (LaTex?) equations using google Chrome

  1. So... All that stuff with {}{}{} around it, is supposed to look nice? And here I've been trying to learn to read it like a new syntax. (Which I guess it is.) But I hear it's supposed to look like nice stuff, and I needn't be translating it via my head. I'm using google chrome, and have java script enabled. What else is necessary to see this the way it's intended?
  2. jcsd
  3. lisab

    Staff: Mentor

    I use Chrome too, and I've found that pages with equations now take a long time to load (like 20 seconds). Is that something you're experiencing, too?
  4. Not here, that is the first time I found a latex containing post in chrome it took maybe a second. Subsequent tries were much quicker, roughly on par with IE9
  5. Redbelly98

    Redbelly98 12,045
    Staff Emeritus
    Science Advisor
    Homework Helper

    Can you post a link to show us what you are talking about?
  6. For example,


    What should I see? I see curly brackets around terms like mbox, erf, sqrt, exp, etc.

    I kind of got the impression that this should display as math is handwritten, not with all those curly brackets. Maybe I'm wrong though?
  7. Evo

    Staff: Mentor

    Please don't start a new thread unless you read the most recent, you might find your questions answered.

    It's better to add to a recent thread, and there have been many.

    Have you tried using this test page that was suggested yesterday?

  8. I did check out that page and I honestly did try to find an answer in the other threads but I couldn't. Sorry if I missed it. That's where I figured enabling java would fix things, but it didn't, and I didn't see anything else to try.

    When I put \int_{0}^{\infty}\mbox{erf}^2(\sqrt{x})\exp(-x)dx into the test page (and press enter), nothing changes.
  9. Evo

    Staff: Mentor

    Well shoot. I know there was a problem with converting from our old latex to the new mathjax format and I thought someone had found a solution.

    Did you look through this thread?
  10. Redbelly98

    Redbelly98 12,045
    Staff Emeritus
    Science Advisor
    Homework Helper

    You need to type [ tex ] before those symbols, and [ /tex ] right after them -- but without the spaces inside those square brackets. Then you'll see this:


    If you want the symbols to appear within the same line as regular text, then use [ itex ] and [ /itex ] instead. For example [itex]\mbox{erf}^2(\sqrt{x})[/itex] and stuff like that.
  11. Fredrik

    Fredrik 10,578
    Staff Emeritus
    Science Advisor
    Gold Member

    The Enter key doesn't do anything. You have to click outside the box. Also, it's javascript that needs to be enabled, not java, but maybe that's what you meant.

    You don't need tex or itex tags on that test page, but you need them in forum posts.
  12. Okay, I poured over that whole thread. I went to this link: and I could see the quadratic formula nicely. Clicking outside the box on the other test page didn't change anything. Adding [ tex ] [ /tex ] without the spaces didn't change it either, but maybe that's my fault. Yes, I meant java script, and that brings up a point; I'm not savy to the lingo (latex, itex, tex tags, etc). I'm not supposed to download mathjax, am I? I'm clueless here, I really need help. Self exploration is getting me no results. I'm not trying to type this stuff, that can come another day. I just want to see it properly. Curly brackets everywhere I look.......
    Last edited: Jul 19, 2011
  13. Fredrik

    Fredrik 10,578
    Staff Emeritus
    Science Advisor
    Gold Member

    You don't need to download anything. It should work in any browser with javascript enabled. (For example, you should see an integral sign (and more) in Redbelly98's post above). Does it work when you use another browser? (You should try it even if you don't want to switch, just so we can rule out some theories about why this doesn't work for you).
  14. It displays correctly for me in IE and Firefox. Sure is pretty. Didn't know what I was missing.
  15. jhae2.718

    jhae2.718 1,152
    Gold Member

    [itex]\LaTeX[/itex] works fine for me in Google Chrome 12.0.742.124 running on 64-bit Xubuntu 11.04.
  16. Are there some settings anyone could suggest for me to check?
  17. Doc Al

    Staff: Mentor

    Did you see post #9?

    I use Chrome and see no problems with Latex.
  18. Try right-clicking on an equation > Settings > Math Renderer > HTML-CSS

    Edit: If you can't get access to the MathJax menu, try deleting the cookies for this site. The settings for MathJax are stored in the cookie I believe.
    Last edited: Jul 21, 2011
  19. Post #9 says how to type it, not how to get it to display. I know chrome shows it fine for most people. I'm trying to get some help adjusting MY chrome so I can see it like everyone else.
  20. Right clicking on the text that should be an equation doesn't return a "settings" option.

    I don't know what this means.
  21. MathJax settings are stored in a cookie. It's possible that the cookie is corrupt or a specific setting is causing a problem.

    I don't use Chrome so I do not know how to access cookies on that browser.
Know someone interested in this topic? Share this thead via email, Google+, Twitter, or Facebook

Have something to add?