Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Integrating derivate of Dirac: Where is my fault?

  1. Jul 6, 2010 #1
    Hi,

    I want to do the following calculation:

    [tex]
    c_{m,n} = \int_{-\infty}^{\infty} t^m \phi(t-n)\,dt
    [/tex]

    I know three things:
    • I know the values of [tex]c_{m,n}[/tex] for m={0,1} and the first 4 for m={2,3}
    • I know that my [tex]\phi[/tex] is symmetric, i.e. [tex]\phi(t) = \phi(-t)[/tex]
    • The fourier transform of [tex]\phi(t)[/tex], i.e. [tex]\Phi(\omega)[/tex]

    This is how I tried solving the problem:

    [tex]
    c_{m,n} = \int t^m \phi(t-n)\,dt =
    \int t^m \phi(-(n-t))\,dt[/tex]

    because of the symmetry

    [tex] = \int t^m \phi(n-t)\,dt[/tex]

    ...is exactly the definition of a convolution...

    [tex](t^m * \phi)(n) = \mathcal{F}^{-1}\left\{ \mathcal{F}\left\{t^m\right\} \Phi(\omega)\right\} = \mathcal{F}^{-1}\left\{ j^m \sqrt{2\pi} \delta^{(n)}(\omega) \Phi(\omega) \right\} =
    j^m \sqrt{2\pi} \mathcal{F}^{-1}\left\{\delta^{(n)}(\omega) \Phi(\omega) \right\}
    [/tex]

    Now, writing the inverse fourier transform gives:

    [tex]
    j^m \sqrt{2\pi} \frac{1}{\sqrt{2\pi}} \int_{-\pi}^{\pi} \delta^{(n)}(\omega) \Phi(\omega) e^{j\omega n}\,d\omega = j^m \int_{-\infty}^{\infty} \delta^{(n)}(\omega) \underbrace{\Phi(\omega) e^{j\omega n}}_{f(\omega)}\,d\omega
    [/tex]

    Now it is well known that

    [tex]\int \delta^{(n)}(x) f(x)\,dx = (-1)^n f^{(n)}(0)[/tex]

    so that

    [tex]
    j^m \int_{-\infty}^{\infty} \delta^{(n)}(\omega) f(\omega)\,d\omega = j^m (-1)^m \left. \frac{\partial^m}{\partial \omega^m} f(\omega) \right|_{\omega = 0}
    [/tex]

    So the whole procedure should reduce to calculate the derivative of [tex]f(\omega)[/tex] and set the result to zero. I fill in my known [tex]\Phi(\omega)[/tex]:

    [tex]
    f(\omega) = \mathrm{sinc}^2 (\omega/2) \sqrt{ 1 - \frac{2}{3} \sin^2(w/2)} \cdot e^{j\omega n}
    [/tex]

    Problem 1: Even the 0th derivative is only computable via a limit. Calculating the limit with [tex]\omega \rightarrow 0[/tex] gives the result:

    [tex]\sqrt{\frac{2}{2+\cos(2)}}[/tex]

    But this is not true. The result should be 1 for [tex]m=0[/tex].

    The result for [tex]m=1[/tex] should be linear: {0,1,2,3,...}. But as you can verifiy the result with my approach is constant.

    Also the result for m={2,3} should give a a quadratic and cubic function. But with my approach it stays constant; Even worse, the solution is not always real!

    .... So there is anywhere a mistake. Can anybody help me where?

    Thank you,
    divB
     
  2. jcsd
  3. Jul 6, 2010 #2

    Mute

    User Avatar
    Homework Helper

    You calculated the limit of [itex]f(\omega)[/itex] incorrectly. f(0) = 1, as is easily seen by just plugging in [itex]\omega=0[/itex]. (sinc(x) has a removable singularity at x = 0, so sinc(0) = 1, and you don't have to bother with any limit calculations). I would suspect that you're making similar mistakes when calculating the derivatives and setting [itex]\omega=0[/itex]. Your reasoning up to that point otherwise looked okay.

    The first derivative admittedly doesn't look pretty, and you may have to take some limits to evaluate it and the other; if so, since there will probably just be an isolated term that is indeterminate, you can calculate its limit separately from the other stuff. (e.g., if you were to calculate f(0) by a limit, you can safely set [itex]\omega=0[/itex] in the exponential and sine, and then use L'Hopital on the sinc function).

    I used wolframalpha to do the first derivative, and it looks like the result will indeed be n.
     
    Last edited: Jul 6, 2010
  4. Jul 7, 2010 #3
    Indeed, thank you for the hint!

    For m=0:

    But actually this is what I tried first: Just plugging in the 0 gave 1. But then I recalled my Mathematic courses: You must not do it this way. If you encounter any [math]\infty[/math] or 0 in the denominator, you better should calculate limits...

    So I did this. Can you tell me why Mathematica gives me a different result? I thought when taking the limit the result should be the same; and if it is not, there is a problem with the direct way...

    Additionally I plotted the function in Mathematica (without the exponential because this will be 1 anway). As you can see the value at 0 is not 1 but 1.37 ... the same stuff as Mathematica gave symbolically...

    I have attached a screenshot.

    Now to m=1: Indeed, when I use Wolfram Alpha there is a huge amount of expressions but when I just plug in zero, there seems to stay just n.

    Now I tried also something which I did not yesterday: I did the second derivative in Mathematica. Again, just setting [tex]\omega=0[/tex] gives an error. But using the limit, I get

    [tex]
    \lim_{\omega \rightarrow 0} \frac{\partial}{\partial\omega} f(\omega) = j n \sqrt{\frac{3}{2+\cos(2)}}
    [/tex]

    The j cancels out, so there stays only the n. But there is again the root which should be 1 ....

    Who is right? And why? Does really Mathematica do a mistake when calculating a limit?

    Regards,
    divB
     

    Attached Files:

  5. Jul 7, 2010 #4
    Haven't looked at the whole problem, but it seems the argument of sine in the first screen is "1" instead of "w/2". If so, Mathematica is right.
    Moreover, in the plot command, there's "Sin[w/w]" instead of "Sin[w/2]".
     
  6. Jul 7, 2010 #5
    Yessss! That was it! Thank you very much!! Plot is not @1.

    And:

    Code (Text):

    In[11]:=
    Limit[D[ToDiff[w],{w,0}],w\[Rule]0]

    Out[11]=
    1

    In[12]:=
    Limit[D[ToDiff[w],{w,1}],w\[Rule]0]

    Out[12]=
    j n

    In[13]:=
    Limit[D[ToDiff[w],{w,2}],w\[Rule]0]

    Out[13]=
    \!\(j\^2\ n\^2\)

    In[14]:=
    Limit[D[ToDiff[w],{w,3}],w\[Rule]0]

    Out[14]=
    \!\(j\^3\ n\^3\)

    [...]
     
    Thank you very much!!! :-)

    Regards
    divB
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook