1. Not finding help here? Sign up for a free 30min tutor trial with Chegg Tutors
    Dismiss Notice
Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Problem with numerical integration

  1. Apr 7, 2006 #1
    Hi all,

    I am having trouble numerically integrating a function using Maple 10. Here is a bit of background on the problem:

    This problem is asking for two plots, one of the velocity of a sounding rocket with respect to time, and the other being the height of the sounding rocket with respect to time. Gravity and drag act on this rocket.

    I have the following equations:

    density as a function of altitude
    drag coefficient as a function of mach number
    mach number as a function of velocity
    drag as a function of drag coefficient
    thrust as a function of mass flowrate and exhaust velocity
    mass as a function of time

    This problem asks to create these plots for various values of mass flowrate that I am supposed to set myself (2 kg/s, 2.1 kg/s, 2.2...etc).

    The known constants that I have are the following:

    specific impulse
    exhaust velocity
    initial mass
    initial velocity
    initial height
    initial density

    After inputting everything into maple, I come up with this differential equation:


    sys1 := [diff(v(t),t) = (thrust-drag-mass*9.81)/mass, diff(y(t),t) = v(t)];


    I am not great with maple, so I am not sure if this is even the correct syntax.

    In my attempt to solve the differential equation, I tried this command:


    sol1 := dsolve(sys1, numeric, v(0)=0, y(0)=0);


    Unfortunately, this gives me the following error:


    Error, (in dsolve/numeric/type_check) insufficient initial/boundary value information for procedure defined problem


    Any suggestions as to what may be causing the problem here? If necessary, I can post my entire maple file if more detail is needed. Thanks in advance.
     
  2. jcsd
  3. Apr 7, 2006 #2

    Tom Mattson

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    That would be good. In fact, why don't you just attach the maple file. That way those of us who have Maple 10 can just download it and run it.
     
  4. Apr 7, 2006 #3
    Hi Tom,

    Attached is my Maple 10 file. Thanks in advance.
     

    Attached Files:

  5. Apr 8, 2006 #4

    Tom Mattson

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    OK, I just tried to look at it but unfortunately I have Maple 9.5 at work, and it has a ton of typesetting error messages. I have Maple 10 at home and will look at it when I get there.
     
  6. Apr 10, 2006 #5
    Thanks for your reply, Tom.

    I have made some progress with this, but I have switched from Maple to Matlab. Attached are my matlab files. When run, I get an error stating:

    "Warning: Failure at t=4.258022e+001. Unable to meet integration tolerances without reducing the step size below the smallest value allowed (1.136868e-013) at time t."
     

    Attached Files:

Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Problem with numerical integration
  1. Numerical Integration (Replies: 12)

Loading...