Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

RTC causing laptop not to boot. Why?

  1. Dec 10, 2012 #1
    Basically, my problem is, sporadically (as far as I can tell), my laptop will get this problem where when I try to boot it, it will start to boot, but hang. The fans will come on, the power lights come on, the harddrive and optical disk drives POST (I can hear them), but the screen remains dead -- no backlight, no BIOS screen, no cursor.

    The only thing that changed before this issue began was that I upgraded my kernel (on Debian) from 3.2 to 3.6. The only indications of a problem was that I got some error messages during the install (dpkg configure) saying that firmware for my ethernet NIC was missing.

    I know it's the RTC because when the problem occurs, I open the back, connect two metal places that reset the RTC when connected, then, when I get it reasembled and try to boot it, it boots fine.

    So, my questions are: why would an RTC problem cause the BIOS to hang? Could this even be related to the linux upgrade or any software whatsoever? Or is it a hardware issue that happened to coincide with a kernel update?

    The first is really just optional. I'm interested in the theory behind why this could happen. The second and third are more important. If this is a hardware problem, I need to send it in to get fixed before my warranty runs out.

    Thanks for any info you can provide,
    Tyler
     
    Last edited: Dec 10, 2012
  2. jcsd
  3. Dec 10, 2012 #2
    You're saying it does this repeatedly, as in you have to reset the CMOS (I don't believe you can only reset the RTC) over and over again?

    In any case, definitely a hardware problem, or BIOS problem -- have you tried updating? The fact that it doesn't even display the POST properly means it's almost(*) certainly not an OS/software issue.

    (*)almost. I suppose you could be loading some really broken code that's doing something to the BIOS when it loads up. Have you tried hitting the FN key combination that changes the laptop between internal and external displays when this happens?
     
  4. Dec 10, 2012 #3
    It is weird, I know, but apparently there is a way to reset *just* the RTC. That's what it says next to the reset pins that fix the problem -- "Reset RTC".

    It doesn't happen reliably. Only sporadically. I haven't been able to specifically link either of my OSes with the recurrence of the problem. I've rebooted from linux (from the new 3.6 kernel) and from windows since I last reset it, and it neither caused it to happened again. It's happened twice in total; once at about 11 last night and again at about 3 today.

    The only way I was thinking software could cause this would be to configure the RTC with some really weird settings (a kernel can change the frequency and IRQ #).

    EDIT: Btw, there is another set of pins for resetting the BIOS. It's labelled "BIOS Crisis". Resetting it doesn't fix the problem.
     
  5. Dec 10, 2012 #4
    Well in modern PCs there are often a lot more registers in the RTC port than there were back when it was just the RTC, so it's conceivable that software that worked back then would screw up systems today. The RTC values used to be reset on a boot but now some hardware has those registers pulling double duty for fairly important things like DRAM timing.

    Even that should not prevent the system from POSTing though. If it's under warranty and you want the peace of mind, take advantage of it before it runs out. ;)
     
  6. Dec 10, 2012 #5
    Sound advice. Thanks. :)

    I think I'll play around with it to see if I can find a way to reproduce it reliably (possibly to correlate it with some software causing it), but if I can't figure it out soon and it keeps happening, I'm definitely gonna get it fixed. Just not looking forward to giving up my laptop for Winter break... :(
     
  7. Dec 10, 2012 #6
    If you manage to reproduce it, try slapping that key a few times just for giggles. It's also possible that the voltage inverter for the backlight is failing. If it's a fluorescent backlight, as most were before LEDs got popular and cost effective, they do tend to fail somewhat randomly. When they do it's very hard to tell if the screen is even on. Get a flashlight and press it up against the screen and you should be able to make out the POST if this is the case.

    I suspect anything 'random' in the CMOS areas, including the RTC, would result in POST beeps indicating a fault; that's what it's there for after all.
     
  8. Dec 14, 2012 #7
  9. Dec 14, 2012 #8
    Well that's bizarre, but at least you seem to have found a solution to your problem. This UEFI stuff is overall a good idea but the early adopters are playing the part of unwitting beta testers as usual!
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: RTC causing laptop not to boot. Why?
  1. Partial boot? (Replies: 4)

  2. Dual booting (Replies: 6)

Loading...