Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Share hover-over

  1. Sep 25, 2013 #1

    dlgoff

    User Avatar
    Science Advisor
    Gold Member

    Share "hover-over"

    While opening a new tab with Firefox, moving the mouse pointer down and over the "Bookmark and Share" button obscures the post so I need to go back up with the pointer to "un-hover" it.

    It's just an annoyance but here's what it looks like.



    attachment.php?attachmentid=62187&stc=1&d=1380122697.jpg
     

    Attached Files:

  2. jcsd
  3. Sep 25, 2013 #2
    What browser and version? Are you saying the drop down doesn't close when you unhover?
     
  4. Sep 25, 2013 #3

    Bandersnatch

    User Avatar
    Science Advisor
    Gold Member

    Happens to me as well, but since it's not only on this site, I got used to it.
    I'm on Firefox v.24.0
     
  5. Sep 25, 2013 #4

    AlephZero

    User Avatar
    Science Advisor
    Homework Helper

    Same thing in Safari (running on Windows not Mac). Sometimes (but not always) it "sticks open" and you have to find the right place to click to close it, or scroll it off the screen which seems to get rid of it.

    I suspect it has something to do with which other windows the mouse goes over, but since it mostly "sticks open" for me when I mouse over it unintentionally, I don't know exactly what I did to make it happen.

    Maybe it's not the "share" window sticking open, but other window(s) not getting refreshed? (just a guess).

    But the current design is much better than some previous ones - "sharing" available for those who want it, and no speed degradation for those who don't!
     
  6. Sep 25, 2013 #5
    Hmmm I can't replicate. I'm using FF24 on win7 and when I hover off, it closes.
     
  7. Sep 25, 2013 #6

    mfb

    User Avatar
    2016 Award

    Staff: Mentor

    I get the same bug from time to time - not always, and not in a reproducible way. Firefox.
     
  8. Sep 25, 2013 #7

    OmCheeto

    User Avatar
    Gold Member
    2016 Award

    The bug is fixed, on my end. Thank you Greg.
     
  9. Sep 25, 2013 #8

    dlgoff

    User Avatar
    Science Advisor
    Gold Member

    Firefox 23 and Windows 7. Yes, when "going through" the button after using the mouse to pickup a thread and drop it on the tab bar. Moving the mouse from the newly created tab across the button down to the post text. I usually use the scroll wheel at this point to move down the thread to read the next post. But I have to hover and un-hover in order to read the top post. That's how I noticed it. But now I can't reproduce it.
     
  10. Sep 26, 2013 #9

    collinsmark

    User Avatar
    Homework Helper
    Gold Member

    For me it's [STRIKE]always[/STRIKE] often getting in the way of my QUICK LINKS. Particularly if I want to got to my "Subscribed Threads," the share thing often gets in the way. And since it's right there where I'm trying to click, the hover won't go away. (And I have to play a balancing game of staying on the quick links pull down, but being careful not to accidentally get close to the share area.)

    [Edit: And as dlgoff and others have implied, sometimes the share menu just won't go away, even though the mouse is nowhere near it anymore. It just happened to me again just a second ago, although it's difficult to reproduce. But I can at least confirm that it does happen. I'm using Firefox 23.0.1 at this moment, about to upgrade to version 24 momentarily.]

    attachment.php?attachmentid=62222&stc=1&d=1380234317.jpg
     

    Attached Files:

    Last edited: Sep 26, 2013
  11. Sep 26, 2013 #10

    phinds

    User Avatar
    Gold Member
    2016 Award

    I also find it obnoxious
     
  12. Sep 26, 2013 #11
    Any better collinsmark? I use Chrome and FF and neither present any problem for me. The hover goes away pretty quick and doesn't interfere with the quick links drop downs. I mean if you hover off the quick links drop down at hit the edge of the share button it does popup, but it goes away if you hover off it a bit. Not a big deal imo. Just tried Opera and IE and no problems.
     
  13. Sep 26, 2013 #12

    phinds

    User Avatar
    Gold Member
    2016 Award

    Why not get rid of the hover and make it so that you have to actively click on the "share" for it to do anything. That way folks can share if they want but we get rid of that obnoxious pop-up
     
  14. Sep 26, 2013 #13
    I can look into that, not sure if it's possible.
     
  15. Sep 26, 2013 #14

    collinsmark

    User Avatar
    Homework Helper
    Gold Member

    I just happened again (I'm on Firefox version 24.0 now). I moused over it and the menu stuck there (I counted to 20 and still nothing), even though the mouse had since moved far away. I then moused over the menu again, moved the mouse away, and the menu disappeared shortly thereafter. But it did require that second mouseover.

    I have a hypothesis that the problem (where the share menu doesn't disappear on its own) happens when the browser has been sitting idle for awhile, or perhaps when the whole computer has been sitting idle for awhile (say around 10 to 15 minutes or so), then the share menu is moused over. I was away from my desk just before it happened this time (and possibly the times before, but I don't recall 100%). I'll keep an eye on it now and let you know.
     
  16. Sep 26, 2013 #15

    phinds

    User Avatar
    Gold Member
    2016 Award

    Yep, that's the same problem I have. Very annoying.
     
  17. Sep 26, 2013 #16

    collinsmark

    User Avatar
    Homework Helper
    Gold Member

    Just happened again, except this time I wasn't away from the computer nor was my browser sitting idle (I was reading some articles on Yahoo! news).

    So perhaps the menu sticks the first time the share thing is moused over after not having been moused over for awhile (and when using Firefox).
     
  18. Sep 26, 2013 #17
    Everyone I mouse off it disappears after about 1 second.
     
  19. Sep 26, 2013 #18
    Mine too...both chrome and IE.
     
  20. Sep 27, 2013 #19

    phinds

    User Avatar
    Gold Member
    2016 Award

    It definitely does NOT always disappear after I mouse off of it, regardless of how long the mouse is off of it. Here's a screen shot after 10 seconds or so:

    attachment.php?attachmentid=62242&stc=1&d=1380302604.jpg
     

    Attached Files:

  21. Sep 27, 2013 #20
    What browser and version phinds? I don't have an explanation why the same exact browser delivers two different results. Are you using any plugins or extensions?
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Share hover-over
  1. Share drop down (Replies: 12)

  2. Slower hover-overs (Replies: 3)

Loading...