Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Booting linux from usb using grub

  1. Jul 8, 2009 #1

    daniel_i_l

    User Avatar
    Gold Member

    I've tried booting multiple distros from a usb (slux, puppy, ubuntu) using grub. When I turn on the computer with the usb, grub loads. But when I select any of the distros I get:
    Error 15: file not found.
    I tried changing the root from root=(hd0,0) to all the possible combinations and nothing worked. Lilo on the other hand worked on two different usb's with all of the above distros. Does anyone have any ideas as to why lilo can boot from a usb and not grub? Is there anything special that has to be done to grub to make it boot from a usb?
    One thing that seemed strange was that lilo doesn't make you specify a device name (just the fact that it's a usb) and grub does. Is grub having trouble with device names when trying to boot things from a usb?
    Thanks,
    Daniel
     
  2. jcsd
  3. Jul 8, 2009 #2
    I can't answer your question (so maybe I shouldn't be replying?), but I'm curious:

    Do you have multiple OSs on the USB drive? What is it that you're trying to accomplish?

    I boot Fedora from USB on occasion, and depending on what computer I'm using, I need to either change the bios to modify the boot order, or the computer recognizes the bootable USB and asks if I want to boot from it - no grub needed...

    -Kerry
     
  4. Jul 11, 2009 #3
    First you need to make sure that usb is bootable

    then press C in grub, ( I assume hd0 is your harddisk, so hd1 will be usb)

    enter these commands :
    root (hd1,0)
    chainloader +1
    boot

    it should give the control to usb's bootloader now.
     
  5. Jul 11, 2009 #4

    daniel_i_l

    User Avatar
    Gold Member

    Hi, the usb's bootloader starts, the problem is that it can't find the files (kernel + initrd) on the usb.
    Thanks
     
  6. Jul 11, 2009 #5
    I have had nothing but pain trying to boot from USB. My advice: stick with a regular live CD.
     
  7. Jul 11, 2009 #6
    What distribution is this ? If you succesfully copied the contents, it shouldnt give such an error.
     
  8. Jul 13, 2009 #7

    daniel_i_l

    User Avatar
    Gold Member

    I've solved the problem:
    While I was installing grub to the usb, grub called my usb device (hda1,0). But when grub boots from a usb it always calls it (hd0,0). So the device map I used to install grub was wrong.
    Thanks for all the help.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Booting linux from usb using grub
  1. Linux wont boot (Replies: 7)

  2. Vista/Linux Dual Boot (Replies: 5)

  3. OS boot from a USB (Replies: 5)

Loading...