Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Convergence problems in ANSYS batch mode but not in GUI

  1. Mar 14, 2017 #1
    Dear experts,

    I´m performing a non-linear buckling analysis under ANSYS Mechanical APDL (v14.5) using an input file that processes the last converged step to generate some etable output.

    When run in GUI everything goes fine: the non-linear buckling analysis is performed until it becomes non-convergent, the previous to last step is selected, and the wanted etable is generated. However, if the input file is run in batch mode (command line) (*), it dumps the following convergence error and exits without generating the etable:
    *** ERROR *** Solution not converged at time 0.6885 (load step 1 substep 71). Run terminated.

    I´ve tried some workarounds using " NCNV,0 " (**) or " NERR,,,-1 " (***) commands. Both commands work in GUI, i.e. they do not exit non-linear analysis and continue execution, but only NERR does it in batch. The problem is that this way more non-convergent steps are performed than necessary so both runs will be slower and, more important, I can´t select the "previous to last step" to get the etable results I want.

    PLEASE, WOULD YOU HELP ME ??? Any help is highly appreciated! Thanks in advance!


    *Command to run ANSYS from windows 10 command line:
    "c:\Program Files\ANSYS Inc\v145\ansys\bin\winx64\ANSYS145.exe" -b nolist -s noread -p ansys -i mynonlinear.txt -o mynonlinear.out

    **NCNV sets the program behavior upon nonconvergence if the solution fails to converge: 0= Do not terminate analysis, 1= terminate program execution and analysis, or 2= terminate analysis but not execution (valid in SOLU processor).

    ***NERR,,,-1 Ignores all errors and performa all non-convergent steps in non-linear analyisis (valid in all processors).
     
  2. jcsd
  3. Mar 20, 2017 #2
    Thanks for the thread! This is an automated courtesy bump. Sorry you aren't generating responses at the moment. Do you have any further information, come to any new conclusions or is it possible to reword the post? The more details the better.
     
  4. Dec 18, 2017 #3
    hi,,, Ihave the problem ..the solution not converged run terminate ???how solve it
     
  5. Dec 18, 2017 #4
    Hi douaa, I'm sorry, but I haven't solve the problem yet... I hope you be more lucky!
     
  6. Dec 18, 2017 #5
    when i reduce load the solution is done .but i know that not ok
     
  7. Dec 18, 2017 #6

    Nidum

    User Avatar
    Science Advisor
    Gold Member

    Could be that the run is just timing out . Try setting a longer allowable run time .
     
  8. Dec 18, 2017 #7
    i active arc length and sub step equal=100 ,and i tried to increase substep but problem not solve ??
     
  9. Dec 18, 2017 #8
    Douaa, does your problem happen only running in batch mode (from command line) or it also occurs in GUI?
     
Share this great discussion with others via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted