1. Not finding help here? Sign up for a free 30min tutor trial with Chegg Tutors
    Dismiss Notice
Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Java calculations w/ conditional statements

  1. Apr 29, 2008 #1
    I'm supposed to calculate the cost of renting a Ford, Cadillac or Toyota, and use conditional statements to calculate the different costs of each vehicle.

    users are supposed to enter “F” for Ford, “T” for Toyota, or “C” for Cadillac

    users enter “F” for Ford, “T” for Toyota, or “C” for Cadillac

    The type of car can only be a Ford, a Cadillac, or a Toyota. Fords rent for $26 per day and .15 per mile. Cadillacs rent for $65 per day and .25 per mile. Toyotas rent for $40 per day and .18 per mile. The total charge will include the number of days rented * the daily rental charge + the number of miles driven * the per mile rate. The first 100 miles are free, so there will be no mileage charge for miles under 100. For miles over 100, only those miles over 100 are to be charged. Therefore, if a car is driven 145 miles, the chargeable miles will be 45.

    I've attempted to code this with if and else if statements, but for whatever reason the calculation does not go through and just shows up as "$0.00"

    here is the code from my computation class:
    Code (Text):
    public class Calculate
    {
        private double milesDrivenDouble, summaryMilesDrivenDouble;
        private static double totalCostDouble, mileageCostDouble, dailyCostDouble,
        summaryCostDouble, fordGrandTotalDouble, cadillacGrandTotalDouble, toyotaGrandTotalDouble;
        private static int daysRentedInteger, summaryCarsDouble, carCounterInteger, fordCounterInteger,
        cadillacCounterInteger, toyotaCounterInteger;
        private static String carType;
        private final double FORD_DAILY_RATE = 26;
        private final double FORD_PER_MILE_RATE = 0.15;
        private final double CADILLAC_DAILY_RATE = 65;
        private final double CADILLAC_PER_MILE_RATE = 0.25;
        private final double TOYOTA_DAILY_RATE = 40;
        private final double TOYOTA_PER_MILE_RATE = 0.18;
        private double MILES_COUNTED = milesDrivenDouble - 100;
       
        public Calculate()
        {}
       
        public Calculate(double milesDrivenDouble, int daysRentedInteger)
        {
            setMiles(milesDrivenDouble);
            setDaysRented(daysRentedInteger );
            calculateFord();
            calculateCadillac();
            calculateToyota();
        }
       
        private void setMiles(double milesDrivenNewDouble)
        {
            //assign public variable to private
            milesDrivenDouble = milesDrivenNewDouble;
        }
        private void setDaysRented(int daysRentedNewInteger)
        {
            //assign public variable to private
            daysRentedInteger = daysRentedNewInteger;
        }
       
        private void setCarType(String carTypeNew)
        {
            //assign public variable to private
            carType = carTypeNew;
        }
       
        private void calculateFord()
        {
                if(carType == "F" && milesDrivenDouble <= 100)
        {
                mileageCostDouble = FORD_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = FORD_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else
                {
                totalCostDouble = 0 + dailyCostDouble;
               
        }
                fordCounterInteger++;
                summaryCostDouble += totalCostDouble;
                fordGrandTotalDouble += totalCostDouble;
                   
        }
           
        private void calculateCadillac()
        {
                if(carType == "C" && milesDrivenDouble <= 100)
        {
                mileageCostDouble = CADILLAC_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = CADILLAC_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else if(carType =="C" && milesDrivenDouble <= 100)
                {
                mileageCostDouble = 0;
                dailyCostDouble = CADILLAC_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
               
        }
                cadillacCounterInteger++;
                summaryCostDouble += totalCostDouble;
                cadillacGrandTotalDouble += totalCostDouble;
                   
        }
       
        private void calculateToyota()
        {
                if(carType == "T" && milesDrivenDouble <= 100)
        {
                mileageCostDouble = TOYOTA_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else if(carType =="T" && milesDrivenDouble <= 100)
                {
                mileageCostDouble = 0;
                dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
               
        }
                toyotaCounterInteger++;
                summaryCostDouble += totalCostDouble;
                toyotaGrandTotalDouble += totalCostDouble;
                   
        }
       
           
        public double getTotalCost()
        {
            //returning total cost
            return totalCostDouble;
        }
        public double getSummaryCost()
        {
               // return shipping cost
            return summaryCostDouble;
        }
       
        public int getCarCounter()
        {
            //return tax
            return carCounterInteger;
        }
       
    }

     
    what did i do wrong?
     
    Last edited: Apr 29, 2008
  2. jcsd
  3. Apr 29, 2008 #2
    There's two things i'd note with your code;

    It's very hard to read, by convention a method should normally be written like:

    Code (Text):
    private void calculateToyota() {
        if(carType == "T" && milesDrivenDouble <= 100) {
            mileageCostDouble = TOYOTA_PER_MILE_RATE * MILES_COUNTED;
            dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
            totalCostDouble = mileageCostDouble + dailyCostDouble;
            }
    }
     
    Tabbing each block enables easier reading. I don't mean this in a condescending manner, I just think it'll make debugging easier in the long term for you!

    Also, your code seems very long for the design spec! Why have you got three separate methods? The formula to work out the expense is the same for each car! Careful use of variables could shorten your code drastically and make it easier to spot potential errors..

    Consider this:

    We have three "input variables" that we need to get from the user to perform our calculation;

    1. Car type.
    2. Number of days rented.
    3. Number of miles covered.

    Then run three conditional statements;

    Code (Text):

    double dailyRate;
    double mileRate;

    if (carType == "C") {
            dailyRate = 65;
            mileRate = 0.25;
    } else if (carType =="F") {.....
    }
    .
    .
    .
    if ((numberOfMiles- 100) <= 0) { numberOfMiles= 0; }

    double amountOwed = ((dailyrate * numberOfDaysRented) + (numberOfMiles * mileRate));

    System.out.println("The amount owed is: " + amountOwed);
     
    Et voila?
     
    Last edited: Apr 29, 2008
  4. Apr 29, 2008 #3
    N.B - I glanced at your code, I think your problem is here:

    Code (Text):

        private void calculateToyota()
        {
                if([B]carType == "T" && milesDrivenDouble <= 100[/B])
        {
                mileageCostDouble = TOYOTA_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else if(carType =="T" && milesDrivenDouble <= 100)
                {
                mileageCostDouble = 0;
                dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
               
        }
     
    The part in bold should be "> 100" (greater than 100) not "<=" (less than or equal to 100)!
     
  5. Apr 29, 2008 #4
    I forgot to say, I fixed those operator errors and here's my fixed code:

    Code (Text):
    /*
     
    public class Calculate
    {
        private double milesDrivenDouble, summaryMilesDrivenDouble;
        private static double totalCostDouble, mileageCostDouble, dailyCostDouble,
        summaryCostDouble, fordGrandTotalDouble, cadillacGrandTotalDouble, toyotaGrandTotalDouble;
        private static int daysRentedInteger, summaryCarsDouble, carCounterInteger, fordCounterInteger,
        cadillacCounterInteger, toyotaCounterInteger;
        private static String carType;
        private final double FORD_DAILY_RATE = 26;
        private final double FORD_PER_MILE_RATE = 0.15;
        private final double CADILLAC_DAILY_RATE = 65;
        private final double CADILLAC_PER_MILE_RATE = 0.25;
        private final double TOYOTA_DAILY_RATE = 40;
        private final double TOYOTA_PER_MILE_RATE = 0.18;
        private double MILES_COUNTED = milesDrivenDouble - 100;
       
        public Calculate()
        {}
       
        public Calculate(double milesDrivenDouble, int daysRentedInteger)
        {
            setMiles(milesDrivenDouble);
            setDaysRented(daysRentedInteger );
            setCarType(carType);
            calculateFord();
            calculateCadillac();
            calculateToyota();
        }
       
        private void setMiles(double milesDrivenNewDouble)
        {
            //assign public variable to private
            milesDrivenDouble = milesDrivenNewDouble;
        }
        private void setDaysRented(int daysRentedNewInteger)
        {
            //assign public variable to private
            daysRentedInteger = daysRentedNewInteger;
        }
       
        private void setCarType(String carTypeNew)
        {
            //assign public variable to private
            carType = carTypeNew;
        }
       
        private void calculateFord()
        {
                if(carType == "F" && milesDrivenDouble <= 100)
        {
                mileageCostDouble = FORD_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = FORD_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else if(carType == "F" && milesDrivenDouble > 100)
                {
                dailyCostDouble = FORD_DAILY_RATE * daysRentedInteger;
                totalCostDouble = dailyCostDouble;
               
        }
                fordCounterInteger++;
                summaryCostDouble += totalCostDouble;
                fordGrandTotalDouble += totalCostDouble;
                   
        }
           
        private void calculateCadillac()
        {
                if(carType == "C" && milesDrivenDouble <= 100)
        {
                mileageCostDouble = CADILLAC_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = CADILLAC_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else if(carType =="C" && milesDrivenDouble > 100)
                {
                dailyCostDouble = CADILLAC_DAILY_RATE * daysRentedInteger;
                totalCostDouble = dailyCostDouble;
               
        }
                cadillacCounterInteger++;
                summaryCostDouble += totalCostDouble;
                cadillacGrandTotalDouble += totalCostDouble;
                   
        }
       
        private void calculateToyota()
        {
                if(carType == "T" && milesDrivenDouble <= 100)
        {
                mileageCostDouble = TOYOTA_PER_MILE_RATE * MILES_COUNTED;
                dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
                totalCostDouble = mileageCostDouble + dailyCostDouble;
        }
                else if(carType =="T" && milesDrivenDouble > 100)
                {
                dailyCostDouble = TOYOTA_DAILY_RATE * daysRentedInteger;
                totalCostDouble = dailyCostDouble;
               
        }
                toyotaCounterInteger++;
                summaryCostDouble += totalCostDouble;
                toyotaGrandTotalDouble += totalCostDouble;
                   
        }
       
           
        public double getTotalCost()
        {
            //returning total cost
            return totalCostDouble;
        }
        public double getSummaryCost()
        {
               // return shipping cost
            return summaryCostDouble;
        }
       
        public int getCarCounter()
        {
            //return tax
            return carCounterInteger;
        }
       
    }
     
    Last edited: Apr 29, 2008
  6. Apr 30, 2008 #5
    please check ww.youngcoders.com/showthread.php?p=142756#post142756 if you dont mind?
     
  7. Apr 30, 2008 #6
    all of your answers are there, I think you just want other people to do your work for you...
     
  8. Apr 30, 2008 #7
    Bad clook!
     
  9. Apr 30, 2008 #8
    Thanks for the heads up.

    It's a bit of a pain to be helping you with a problem that you've asked on another forum (and may already be solved for all I know!)
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Java calculations w/ conditional statements
Loading...