Keyboard gives me funny characters

In summary, the conversation discusses an issue where if you are using Outlook Express on a Windows 7 machine, pressing the ? key will instead give you a é. The solution is to disable any other language keyboards, relaunch Outlook Express, or define the input language through the control panel.
  • #1

DaveC426913

Gold Member
22,396
6,083
This happens occasionally. Never been able to figure out why or how to revert it.

It's often varying causes and effects but right now, when I am in Outlook Express on W7, if I press the ? key, I instead get a É.

I'm sure it's a keystroke combination that activates some obscure language setting such as a French kb, but I don't know how to revert it.

I've gone into Control Panel keyboard and checked to make sure that English US is the only thing listed. No joy.
 
Computer science news on Phys.org
  • #2
DaveC426913 said:
I've gone into Control Panel keyboard and checked to make sure that English US is the only thing listed. No joy.

On my (WinXP) system, "Keyboard" is about the hardware, not the software. Try
Control Panel
Regional and Langauge Options
Languages tab
Details button for Text services and input languages.
 
  • #3
Maybe Outlook Express is doing this. In the Tools menu, select Options, and then select the Read tab. In the lower pane, click International Settings. See if there's something amiss there.
 
  • #4
Mark44 said:
Maybe Outlook Express is doing this. In the Tools menu, select Options, and then select the Read tab. In the lower pane, click International Settings. See if there's something amiss there.

It probably is, as it does not occur in other apps, such as this one (eg.: ?)

Alas, MS*, in its infinite wisdom has determined that, since this month has a vowel in it, it will completely re-do Outlook's interface. The is no Tools menu anymore. Apparently, their UX team has determined that users no longer want it.


*($*%@!$%)
 
  • #5
What version of Outlook Express are you running, Dave? It might be that there is a setting somewhere that turns on or off the Tools menu.
 
  • #6
Mark44 said:
What version of Outlook Express are you running, Dave? It might be that there is a setting somewhere that turns on or off the Tools menu.

I found what passes for the Tools menu option.

No effect.

What did work was relaunching Outlook.
 
  • #7
This issue occurs when you have more than 1 language keyboard enabled. For example, English(canadian) selected as your language. There is a keyboard shortcut that will switch the keyboard type between english and french.

Hold Down Ctrl+Shift (in that order) and continue to hold for 5 seconds.
This will swap between the different types of keyboards
After 5 seconds, release the keys and restart your application.

You can also define the input language though the control panel>Regional & Language>Keyboard and Language
remove all but US English from the list and this will permanently resolve this issue.
BE CAREFUL when removing stuff.
 
  • #8
Routaran said:
You can also define the input language though the control panel>Regional & Language>Keyboard and Language
remove all but US English from the list and this will permanently resolve this issue.
BE CAREFUL when removing stuff.

Recommendation: remove all keyboards except US keyboard.
Another keyboard will always function the wrong way.

If you want you can keep more than one language for ease of the use of accents if you are into that.
You'll have to be careful though which one is active.
 
  • #9
I like Serena said:
Recommendation: remove all keyboards except US keyboard.

American cultural imperialism strikes again! :smile:
 
  • #10
AlephZero said:
American cultural imperialism strikes again! :smile:

I should have said: "assuming you are from the US and have a US keyboard".
(Which I have, but I'm not from the US! :wink:)
 
  • #11
im not from the US either lol
but i figured its an ok assumption
 

1. Why is my keyboard typing the wrong characters?

There could be several reasons for this issue. One possibility is that the keyboard language settings have been changed, causing different characters to be typed. Another possibility is that there is a hardware issue with the keyboard itself, such as a stuck key or a faulty connection.

2. How do I change my keyboard back to the correct characters?

To change the keyboard language settings, you can go to the control panel on your computer and select "Region and Language" or "Language and Input". From there, you can choose the correct language and keyboard layout. If that does not work, try restarting your computer or checking for any updates for your keyboard driver.

3. Why are my keys producing symbols instead of letters?

This can happen if the "Num Lock" or "Caps Lock" keys are accidentally pressed. Make sure both of these keys are turned off. If the issue persists, try cleaning the keyboard to remove any debris that may be causing the keys to stick.

4. What should I do if my keyboard is still typing strange characters after changing the settings?

If changing the keyboard settings did not fix the issue, it is possible that there is a hardware problem with the keyboard. Try using a different keyboard to see if the issue persists. If it does, then the issue may be with your computer's motherboard or input device.

5. Can a virus or malware cause my keyboard to type funny characters?

Yes, it is possible for a virus or malware to affect your keyboard's functionality. If you suspect that this is the case, run a virus scan on your computer and make sure your operating system and security software are up to date. If the issue persists, it may be necessary to seek professional help to remove the virus or malware.

Suggested for: Keyboard gives me funny characters

Replies
5
Views
120
Replies
19
Views
1K
Replies
2
Views
1K
Replies
12
Views
1K
Replies
16
Views
1K
Replies
10
Views
2K
Back
Top