Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

[MCNP5] Error when use Fm, De/Dm with Fmesh

  1. Aug 12, 2017 #1
    Hello everyone,
    I do need your help in this matter, please kindly help me solve this problem
    I use MCNP5 and i run a simple example using Fmesh4 and Fm, De / Df but I get an error:
    " fatal error. no tally associated with response function -1"
    " fatal error. no tally associated with fm card -1 "
    2017-08-12_222509.jpg
    If I remove Fm and De / Df or replace Fmesh4 by F4 then there is no error.
    Thank you!
    input:

    1 1 -1 3 5 -4 -2 -6 7
    2 0 -1 #1
    3 0 1

    1 so 30
    2 pz 0
    3 pz -5
    4 px 4
    5 px -4
    6 py 3
    7 py -3

    mode n
    m1 1001.60c -0.111898 $Nuoc
    8016.60c -0.888102
    imp:n 1 1r 0 $ 1, 3
    sdef pos= 0.00000000 0.00000000 15.00000000
    vec= 0.00000000 0.00000000 -1.00000000
    axs= 0.00000000 0.00000000 -1.00000000
    ara= 78.53982
    c The vecor defining the direction of each new particle is set to be
    c perpedicular to the disk's surface
    dir=1.0
    c The angular sampling (mu) of the source is set to one, ensuring the
    c particles are always traveling along the vec direction
    c The dir and vec options ensure a monodirectional source
    rad=d1
    c The radial distribution from the axs vector is distribution d1 (si1,sp1)
    erg=d2
    c The energy distribution is described by si2,sp2
    c
    si1 0 5
    c si1 specifies the radius is be between the discrete values of 0 and 5 cm
    c sp1 -21 1
    c sp1 specifies the distribtion is a power law p(x)=c|x|^a, where a=1
    c This makes the source creation uniform over the disk's area
    c si2 S 5 6 7
    c Energy Distribution for "epithermal" neutron beam
    c 10% thermal (<0.5 eV) 89% epithermal (0.5 eV to and 1% fast
    c sp2 0.1 0.89 0.01
    c sb2 0.05 0.15 0.8
    # si2 sp2
    0 0
    1.00e-09 0.000609576
    1.01e-07 0.99433306
    2.01e-07 0.004941244
    3.01e-07 8.46637E-05
    4.01e-07 1.84198E-05
    5.01e-07 8.43799E-06
    6.01e-07 1.56881E-06
    7.01e-07 1.02785E-06
    8.01e-07 5.95067E-07
    9.01e-07 9.73748E-07
    1.00e-06 4.32776E-07
    fmesh4:n origin -4 -0.5 -5 imesh 4 jmesh 0.5 kmesh 0&
    iints 8 jints 1 kints 5 out=ik
    fm4 1.11e9
    # de4 df4
    2.50e-08 3.67E-06
    1.00e-07 3.67E-06
    1.00e-06 4.46E-06
    1.00e-05 4.54E-06
    1.00e-04 4.18E-06
    1.00e-03 3.76E-06
    1.00e-02 3.56E-06
    1.00e-01 2.17E-05
    5.00e-01 9.26E-05
    1 1.32E-04
    2.5 1.25E-04
    5 1.56E-04
    7 1.47E-04
    10 1.47E-04
    14 2.08E-04
    20 2.27E-04
    nps 5e5
     
  2. jcsd
  3. Aug 13, 2017 #2
    please, help me
     
  4. Aug 14, 2017 #3

    Astronuc

    User Avatar

    Staff: Mentor

    I'm not a user of MCNP, however, I found the following example.

    See some examples in https://dspace.mit.edu/bitstream/ha...51-fall-2005/contents/labs/lab4presentatn.pdf

    Last page in linked file
    c Reaction Rates
    fc4 reaction rates
    f4:n 1100
    sd4 2.10829
    e4 0.625E-6 20.0 T
    fm4 (1.0 1000 (-6))
    (1.0 1001 (102))

    Earlier in the pdf
    F4 Tally example

    F4:N CELL#
    FC4:N YOUR COMMENTS HERE
    E4:N 0.5E-6 20 $ ENERGY STRUCTURE
    FM4:N MULTIPLIERS

    Make sure the syntax for FM, FM4 or F4 tally is correct for one's problem.
     
  5. Aug 14, 2017 #4
    Thank you
    But in this link do not use Fmesh, only use F4.
    I'm sure my syntax is correct because in my article, if I replace Fmesh4 by F4 then run normally or use Fmesh4 and remove Fm, De / Df will run normally.
    I have found an example in manual of MCNP5 that use Fmesh4 with Fm, De / Df (MCNP5_Lattice_Speed_Tally_Report__-_LAUR-04-3400. Page 35), but running on my laptop still have this error. I have tried running on some other laptop and still have the same error. Really can not understand
     
  6. Aug 15, 2017 #5
    Hi,
    there are small problems in your file,
    but if you revise the file it gives that :

    upload_2017-8-15_21-56-1.png

    The problem comes wth the SDEF definition you forgetted the "5 spaces" after:
    vec, axs, ara, dir, rad, erg

    I put my file which is ok with MCNP6 and Moritz,
    hope it helps,
    PSR
     

    Attached Files:

  7. Aug 15, 2017 #6
    Thank you very much.

    I run your file with MCNP5 but still error, maybe MCNP5 can not use Fm, De / Df with Fmesh. Is there any way to be able to calculate Tally F4 the same as using Fmesh?
    MCNP6 has been upgraded a lot, unfortunately my university does not have MCNP6, only MCNP5
     
  8. Aug 16, 2017 at 1:44 AM #7
    Hi,
    I tried my file with MCNP5 and it's ok (see attached file) .
    It's non ok with MCNPX.
    When I look at your first post, it seams that you run MCNP with "vised". Probably "vised" runs MCNPX and not MCNP5. For that read your output file (ASCII file not with vised) and look the first lines: you can know what version of MCNP runs.
    PSR
     

    Attached Files:

  9. Aug 16, 2017 at 5:40 AM #8
    Hi,
    Now I understand. MCNP5 v1.6 can do that.
    How to get it ...? Real headache
    thank you very much
     
  10. Aug 16, 2017 at 9:20 AM #9
    Haha, success!
    I copied the input file to the MCNP VisEd folder (bin folder), and run MCNP5 from CMD
    Thanks everyone
     
  11. Aug 16, 2017 at 9:43 AM #10
    Cool for you
    Hope I helped you a little bit
    PSR
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted



Similar Discussions: [MCNP5] Error when use Fm, De/Dm with Fmesh
  1. MCNP5 help (Replies: 1)

  2. MCNP5 stuck in loops (Replies: 1)

  3. MCNP fmesh with fm (Replies: 1)

  4. MCNP5 (pseudolevels) (Replies: 1)

Loading...