Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Problems with plotting a function in Maple

  1. Mar 3, 2016 #1
    Hey so I'm working on a simulation to compute the multiplicity of two Einstein solids.. long story short I'm having a tough time plotting a function. To start, I defined the following:

    upload_2016-3-4_3-1-5.png

    upload_2016-3-4_3-1-34.png
    Which, when simplified yields:
    upload_2016-3-4_3-1-44.png
    I named this simplified result K:
    upload_2016-3-4_3-2-47.png
    Plotting this...
    upload_2016-3-4_3-3-20.png

    What I get is
    upload_2016-3-4_3-3-58.png

    However if I don't define my axis, Maple yields the following:

    upload_2016-3-4_3-4-45.png

    This is fine, except I would like x to go from 0 to 100 and y to go from 0 to 2E96 (which when computed by hand yields actual results close to the boundaries of that range). However if I manually go into the axes definition of the image above, and change it to the desired values, I get:

    upload_2016-3-4_3-8-17.png

    So the plot is not defined at any value outside of whatever Maple decided it should be: I can only change the axes values but not the range and domain of the actual function.. any ideas?
     
  2. jcsd
  3. Mar 8, 2016 #2

    jedishrfu

    Staff: Mentor

    You could try plotting it using smaller constants just to see if its the function itself somehow.

    It may be that even a small increment in x is either 0 or skyrockets way beyond the range limits hence you see no plot line. Can you change the plot line color that way you would see the line drawn over the x-axis until it takes off toward the moon.

    Or can you zoom in to the plot that is made until you've reached the domain and range you want. You''ll probably find the same result and that the software is working as designed.

    Also have you tried it in MATLAB? Its pretty good about plotting things.
     
    Last edited: Mar 8, 2016
  4. Mar 9, 2016 #3
    I ended up plotting in Mathematica after starting from MATLAB (which didn't work because it approximates infinity at around 7E96 I think, and even when I divided it by 1E96 it would first calculate the factorial, approximate it to infinity, then say infinity divided by a large-ish number is "NaN"). Then I tried to plot it with Maple.. didn't work because of it's approximation of infinity. Tried to do it in Python .. same reason. Ended with Mathematica.. it works wonders :D
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted



Similar Discussions: Problems with plotting a function in Maple
  1. Plotting With Maple (Replies: 1)

Loading...