Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Trouble using the Bethe Formula

  1. Oct 1, 2015 #1
    So I'm doing research with a professor and he wants me to use the Bethe formula to calculate stopping power for alpha particles of various energies, but I'm having a lot of trouble using it, and I figured I'd ask here before I bothered him.
    He wanted me to use the non-relativistic version listed on Wikipedia (from Sigmund 2006, and I've seen it other places in the same form, so I don't think it's a problem with the formula). Here it is: https://en.wikipedia.org/wiki/Bethe_formula
    I was getting very confusing answers, so I tried just going through the formula with nothing but the units and seeing if they worked out. The units we want for dE/dx are eV/m or eV/cm (or Joules/distance, I guess), correct? The main issue I'm having is that, with the units, I keep getting an answer per seconds to the TENTH, when it's only supposed to be seconds squared, and I cannot for the life of me figure out where the extra s^-8 is coming from. My first instinct is that it's from the units of the permittivity squared, but the rest of the units of the permittivity seem to work out fine.
    Any idea where I'm going wrong?
     
  2. jcsd
  3. Oct 1, 2015 #2

    mathman

    User Avatar
    Science Advisor
    Gold Member

    You need to show us how you get the dimensions you see. One wild guess [itex]\beta [/itex] is non-dimensional.
     
  4. Oct 1, 2015 #3

    ChrisVer

    User Avatar
    Gold Member

    isn't [itex]mc^2[/itex] energy? So [energy]-1
    then [itex]\Big( \frac{z^2 e^2}{4 \pi \epsilon_0} \Big)^2[/itex] has [force]2* [lenght]4 = [energy]2 * [length] 2 (distance times force = work = energy)
    and finally [itex]n[/itex] has # / [length]3

    The result is:
    [energy]-1 [energy]2 [length]2 [length]-3 = [energy]/[length] for what I see...
     
  5. Oct 1, 2015 #4
    It turned out that I made a really stupid mistake. When I was looking up Coulomb in base units since I don't know it offhand, I apparently misread it as A/s instead of A*s. Everything works out now. Thanks for replying, everyone. It helped me narrow down to the part of the equation I was messing up on.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Trouble using the Bethe Formula
  1. Bethe formula question (Replies: 3)

  2. Bethe Bloch formula (Replies: 1)

Loading...