Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

VISTA and ASP folder permissions

  1. Aug 27, 2007 #1

    DaveC426913

    User Avatar
    Gold Member

    I'm new to Vista and am trying to run an ASP script to write to a local text file.

    I'm getting error 405: Method Not Allowed - 'an invalid method (HTTP verb is being used)'

    On my XP system, I had to set 'Modify' permissions on the folder for the machine user - I'm not sure if that's the problem here or not.
     
  2. jcsd
  3. Aug 27, 2007 #2

    chroot

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    How can we possibly know? Try giving the folder full-control permissions for everyone and see if that fixes it. Then dial back the permissions until you know which ones are necessary.

    - Warren
     
  4. Sep 6, 2007 #3

    DaveC426913

    User Avatar
    Gold Member

    Found the problem:
    1] You need to set the folder so that IUSR can modify it and anything in it.

    > Right-click on folder, select Properties.
    > Select the Security tab.
    > From Group or user names, select Users (myapp\Users)
    > Select Edit under scroll panel
    > From Group or user names, select Users (myapp\Users)
    > In the bottom panel, Permissions for users, check the Modify : Allow box
    > Under the bottom panel Select Apply
    > Select OK, to close the Permssions for myapp dialogue
    > Near the bottom of the Security panel, select Advanced
    > In the permission entries box, select (myapp\Users)
    > Select Edit.
    > In the permission entries box, select (myapp\Users)
    > At the bottom of the dialogue, check the Replace all existing inheritable permssions… checkbox.
    > Select Apply, then OK.
    > OK to all open dialogue boxes.


    2] Uh, you need to enable ASP. Unlike earlier versions of Windows, Vista comes with ASP and .NET locked down and it needs to be explicitly enabled before use.

    Control Panel > Programs and Features > (left) Turn Windows Featrues on or off > IIS > WWW Services > App Dev Services > ASP : check
     
  5. Sep 6, 2007 #4
    vista sux anyways
     
  6. Sep 6, 2007 #5

    DaveC426913

    User Avatar
    Gold Member

    You know, I thought Mac's latest commercial poking fun was cattily funny but surely not very faithful to reality.

    Having spent two days setting up a half dozen new laptops running Vista I can say with certainty that it is not an exaggeration at all.

    To simply copy a file from one location to another, the system stops what it's doing and pops up a dialogue telling me I will need permission to do that.

    When I select yes, it then greys out the entire screen (in what appears to be the visual equivalent of speaking slowly to a retard) and pops up another dialogue box asking if I initiated the action that I just inititiated, and I should select yes if so.

    It does this with everything.




    You are coming to a sad realization. Cancel or allow?
     
  7. Sep 6, 2007 #6

    Math Is Hard

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    You're kidding, right? Is there any kind of override for the dialog boxes, a "do not show this box again" option?
     
  8. Sep 6, 2007 #7

    DaveC426913

    User Avatar
    Gold Member

    Nothing I could see. It may be a more globally set option. Which of course, is counter-productive to the whole "easier for the unwashed masses to operate" philospohy that is the thorn in the side of more competent users.
     
  9. Sep 6, 2007 #8

    chroot

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    You can turn off the account services so you can truly run as "superuser" all the time and get rid of the annoying dialog boxes.

    The reason the dialog boxes exist is because MS decided to use a real security model for Vista, where users do not run with administrator privileges all the time. The system has to elevate (move to a higher privilege level) frequently, though. The whole grayed-out screen is actually a technique to make sure no one makes malware that simulates the permission dialog box and tricks the user.

    Windows Vista probably is substantially more secure than its predecessors, but it has unfortunately made the user experience much more clumsy in order to achieve that goal. As I've said, though, you can turn the security features off if convenience is more important than security (which is true for most casual users).

    They're really just doing everything they can to lock down freshly installed Windows machines so viruses and worms will have a more difficult time spreading. Corporations have -- shall we say -- tired of losing days productivity over some Latvian 14 year old's attempt at hacking in Visual Basic.

    - Warren
     
    Last edited: Sep 6, 2007
  10. Sep 6, 2007 #9

    chroot

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

  11. Sep 6, 2007 #10
    are we talking about windows vista here??
    if so, vista really sux. it asks for a gpu for even minesweeper. what worse, i couldnt burn any dvd's, it asks for a gpu. what the hell is a gpu supposed to do with dvd burning??
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: VISTA and ASP folder permissions
  1. Content.IE5 Folders (Replies: 3)

  2. New folder (Replies: 11)

  3. Locking a folder? (Replies: 8)

  4. Secret folders (Replies: 16)

Loading...