Word: review comments typing backwards

DaveC426913
Gold Member
18,333
1,940

Main Question or Discussion Point

Help! My comments are appearing backwards in a doc I'm reviewing.

See attached.

What I typed was: [ Hello Bob A1234 ]

The comment reads: [ 1234Hello Bob A :Comment ]
(see attached diagrams)

It builds like this:
[ |H:Comment ]
[ |He:Comment ]
[ |Hel:Comment ]
[ |Hell:Comment ]
[ |Hello:Comment ]
[ |Hello :Comment ]
[ |Hello B:Comment ]
[ |Hello Bo:Comment ]
[ |Hello Bob:Comment ]
[ |Hello Bob A:Comment ]
[ |1Hello Bob A:Comment ]
[ |12Hello Bob A:Comment ]
[ |123Hello Bob A:Comment ]
[ |1234Hello Bob A:Comment ]​
Several things are happening:
1] The 'Comment' header appears on the right of the comment box, with the colon to its left.
2] The text cursor starts at the right and advances left as I type (staying to the left of the building string of text) - even though the text itself accumulates on the right of the text string! (see demo, above)
3] Numbers break the pattern, jumping to the left even without the benefit of spaces.

Tests:
This does not do this in a new, blank document; it is intrinisc to this document.
This does occur on multiple machines; again, intrinsic to this document.
This does occur even if I copy and paste the document's contents into a newly-created document; soit is intrinsic to the content of this document.
Playing with the text style, even the 'Comment text' style has no effect.
This does not occur in other documents from this same source of mine.

I am unable to query the source, or ask for new documents.

My first suspicion is some sort of Arabic language formatting thing where writing is from right to left.

Any ideas what's wrong here?
 

Attachments

Last edited:

Answers and Replies

FredGarvin
Science Advisor
5,050
6
I tried for a bit to replicate the problem, but I couldn't get it to print backwards. Any chance of you deleting the text and posting the file so we can play around with it?
 
DaveC426913
Gold Member
18,333
1,940
Thanks! Here's the doc.
 

Attachments

cristo
Staff Emeritus
Science Advisor
8,056
72
Well, I fixed it, I'll try my best to explain how!

Click so the cursor is in the comment box. Then go to format -> paragraph. On the first tab "indents and spacing" you'll see under general a "direction" You need to change this to "Left to Right"

Hope this helps.
 
DaveC426913
Gold Member
18,333
1,940
Thank you! (I knew it was an Arabic thing...)

Trouble is, I don't have that option. A look through Help:

The feature described in this Help topic is only available if support for a right-to-left language, such as Arabic, is enabled through Microsoft Office Language Settings.

And a look in Microsoft Office Language Settings tells me that this is an XP Pro thing. I have XP Home.

While I can't fix the problem myself, confirming what the problem is gets me halfway there.
 
cristo
Staff Emeritus
Science Advisor
8,056
72
If I change it, save it, then post it back, do you think it will remain corrected on your machine? I can do that, if you think it'll help!
 
DaveC426913
Gold Member
18,333
1,940
If I change it, save it, then post it back, do you think it will remain corrected on your machine? I can do that, if you think it'll help!
I wish I could. I'm doing this on behalf of my wife and I made that suggestion. She categorically ruled that out.

She'll do it, she'll just have to do it through her approved IT channel. But thanks very much for the offer!
 
cristo
Staff Emeritus
Science Advisor
8,056
72
Ahh right, ok. Well, at least you're halfway there! Good luck!
 
FredGarvin
Science Advisor
5,050
6
Darn. That was wierd. I knew it had to do something with the foreign language. The file brought up a lot of different options I have never seen before. My machine has XP Pro and I still did not have the direction option.
 
DaveC426913
Gold Member
18,333
1,940
Darn. That was wierd. I knew it had to do something with the foreign language. The file brought up a lot of different options I have never seen before. My machine has XP Pro and I still did not have the direction option.
So, it worked for cristo but not for you.

Is it possibble you don't have the language options installed? They don't come installed as default. Look up 'language direction' in help
 
FredGarvin
Science Advisor
5,050
6
I probably don't. I was suprised to see some menu options in arabic though.
 
DaveC426913
Gold Member
18,333
1,940
I probably don't. I was suprised to see some menu options in arabic though.
I didn't get that. But of course, I don't have the version installed. Hey cristo, did you get some arabic menu options?
 
cristo
Staff Emeritus
Science Advisor
8,056
72
Hey cristo, did you get some arabic menu options?
Nope, all my menu options are in English as usual. It's very strange how the same document can have different effects on different computers, like this!
 
The easiest solution is to your your document as plain text (*.txt), close Word, open the text document in Notepad, reopen Word and copy and paste the whole text into a blank Word document.

You'll lose any formatting, though.

The problem occurs when the document was created in an Arabic version of Word.
 
DaveC426913
Gold Member
18,333
1,940
The easiest solution is to your your document as plain text (*.txt), close Word, open the text document in Notepad, reopen Word and copy and paste the whole text into a blank Word document.

You'll lose any formatting, though.

The problem occurs when the document was created in an Arabic version of Word.
Well OK thanks. It's been 2 1/2 years ... but thanks...:wink:
 
I know, but other people with the same problem will google it and find this page (that's what I did).
 
1
0
Here is how to get around the problem.

Left Click in the COMMENT FIELD and KEY in "CTRL-A" to select all. Then start typing.

I had a document sent to me from the Middle East and I drove me bonkers! You will have to do this for each comment - just the nature of the two language formats - but it works!
 
Last edited:
173
1
Is it possibble you don't have the language options installed? They don't come installed as default. Look up 'language direction' in help
Dave, have you tried installing various language packs and trying again to go from your halfway point to correcting it fully? You can always uninstall the language packs later.

I'm just as concerned as to how this came about. Was it something you changed? Or was it an overactive (invasive) piece of code that crept onto your system from some website or program you downloaded? Could it have been a macro embedded in a Word document left over from a previous version written in Arabic?
 
DaveC426913
Gold Member
18,333
1,940
Dave, have you tried installing various language packs and trying again to go from your halfway point to correcting it fully? You can always uninstall the language packs later.

I'm just as concerned as to how this came about. Was it something you changed? Or was it an overactive (invasive) piece of code that crept onto your system from some website or program you downloaded? Could it have been a macro embedded in a Word document left over from a previous version written in Arabic?
Well, since I was a significantly younger man at the time...as was whatever version of Windows I was running, let alone Word ... I'm afraid I have no answer now. :wink:
 
173
1
Well, since I was a significantly younger man at the time...as was whatever version of Windows I was running, let alone Word ... I'm afraid I have no answer now. :wink:
Oh. So this happened a while ago? I missed the memo (in your OP, and my bad). And looking back, I see it was in 2007. Who necromaniacly resurrected this thread?

Ah - a one-post-wonder.

I'll reset my radar so as to avoid OPW responses to threads from yesteryear!

- Mugs
 
DaveC426913
Gold Member
18,333
1,940
necromaniacal

:biggrin:
 
Are you collaborating with someone who speaks Arabic or another "right to left" language? This problem happened to me and it was because the default style in the document was formatted in Arabic.
 
S_Happens
Gold Member
300
3
Pretty impressive that it was revived THREE times, and even this time the posted completely ignored both the date AND the content.
 
1
0
Thanks to all who posted about comments coming out backwards. The original document is from Iran, which probably explains why the comments were backwards in my edit.

A special thnk you to Smorge, who offered an easy solution to the problem.

Terry K
 
DaveC426913
Gold Member
18,333
1,940
Will someone puhLEEZE close this 4 1/2 year old thread!
 

Related Threads for: Word: review comments typing backwards

  • Last Post
Replies
18
Views
1K
  • Last Post
Replies
22
Views
3K
Replies
14
Views
8K
Replies
8
Views
5K
Replies
7
Views
779
  • Last Post
Replies
1
Views
5K
  • Last Post
Replies
3
Views
2K
  • Last Post
2
Replies
29
Views
5K
Top