Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

How to prevent cursor from jumping to different places?

  1. Jan 20, 2017 #1
    Hi

    I have been having problem of the cursor jumping to different place in the middle of typing. It jump to middle of the paragraph and start typing and I have to do ctrl-Z to delete the wrong letters and use the mouse to bring the cursor back. It is happening across a few laptops I have.

    I am sure I did not hit anything accidentally, it just happens.

    More predictable is when I write an email, at the beginning, it always jump to the address line and start typing. It is very inconvenient doing that all the time. Is there anything I can do?

    Thanks
     
  2. jcsd
  3. Jan 20, 2017 #2

    phinds

    User Avatar
    Gold Member
    2016 Award

    I had that problem several years ago on a laptop and it turned out that I had inadvertently turned on the touch pad and my thumb was hitting it as I typed and moving the cursor, but mine seemed more random than what you are describing.
     
  4. Jan 20, 2017 #3
    Thanks for the reply, how do you turn off the touch pad? I did not see in the control panel. Mine is always on.
     
  5. Jan 20, 2017 #4

    phinds

    User Avatar
    Gold Member
    2016 Award

    Usually there's a spot on the pad itself or directly above it. Mine's above the pad, my wife's is on the pad in the upper left I think it is. Look up your computer model on line for the manual if all else fails.
     
  6. Jan 20, 2017 #5

    jedishrfu

    Staff: Mentor

    If you have a track point i.e. A little red button in the middle of the keyboard for mouse control then this might be the problem as it moves the cursor to the mouse pointer when pressed. It can be disabled via the system mouse settings panel.

    It would happen to me when I'd type a g or an h and would touch the track point button too and magically the cursor would move to where the mouse was. Very very frustrating.
     
  7. Jan 20, 2017 #6
    Thanks for the reply, I have no red button in the middle of the keyboard, I know about that button can move pointer, I don't have it in all my laptops.

    I have no buttom around the mouse pad. I looked in control panel, mouse, nothing there. I went to device manager, Mice and Other pointing devices, I disable the HID compliant mouse, it disable the real mouse, I had to use the mouse pad to enable it again!!! I went on web to look and no luck so far.
     
  8. Jan 21, 2017 #7
    This was something my mom was complaining about a few months ago, it should be a simple fix by disabling the touchpad. Sounds like you need to install the touchpad driver from the laptop manufacturer to control its functions with the mouse tool in the Control Panel.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?
Draft saved Draft deleted