Register to reply

Slow Computer - External Hard Drive Cause?

by Jiggy-Ninja
Tags: drive, external, slow
Share this thread:
Jiggy-Ninja
#1
Aug9-13, 11:02 PM
P: 310
I've been having a problem lately with my computer. It's running 64-bit Windows 7, and has two external hard drives plugged in.

Occasionally , I've noticed that sometimes when I attempt to do something in a program, even something as single as right-click on a cell in Excel, the computer will hang for a second, sometimes all the programs will become unresponsive to clicks while this is going on. Meanwhile, while waiting for the context menu to open up, I can hear one of my external drives wind up to speed. The program won't respond until the drive has wound up to speed.

The curious thing is that the program I'm working on shouldn't be touching the external drive at all. In fact, the last time it happened, which prompted me to post this, I didn't have anything open that should be accessing that drive. Yet, it still spun up when I right-clicking on something unrelated to it.

Neither drive has ReadyBoot activated, Windows wouldn't allow me to active it on them even if I wanted to. I don't know what might be causing this.
Phys.Org News Partner Science news on Phys.org
What lit up the universe?
Sheepdogs use just two simple rules to round up large herds of sheep
Animals first flex their muscles
DavidSnider
#2
Aug9-13, 11:20 PM
PF Gold
P: 469
Pull up task manager and see which program starts maxing out the CPU
chiro
#3
Aug9-13, 11:52 PM
P: 4,573
On top of DavidSniders advice, if you can't find an application maxing out the CPU, look at the system services and see which one(s) is (are) using a majority if the resources.

rcgldr
#4
Aug10-13, 12:35 AM
HW Helper
P: 7,117
Slow Computer - External Hard Drive Cause?

This probably isn't a cpu issue. I've seen a similar thing happen when a cd / dvd is inserted into a cd / dvd drive, where certain apps will slow down even though they are not accesing the cd / dvd drive.
Borg
#5
Aug10-13, 07:21 AM
PF Gold
Borg's Avatar
P: 771
You might want to try disabling Shell Hardware detection. Doing so will disable autoplay if you can live with that. Here's a link to an article that describes how in three steps.
Windows 7: Scan and Fix Removable Disk Prompt - Disable in Windows
Even though the article appears unrelated, I have seen fewer issues like the one you described since I implemented it on my own computer - plus, I don't get that useless prompt to "Scan and Fix" my external drives anymore.
Bill Simpson
#6
Aug10-13, 09:41 PM
P: 1,037
Unplug the external drives, boot the system and intensely test the system to see if the problem goes away.

A few years ago Win XP could sometimes get the floppy added to the list of paths it needed to check. You could determine this by hearing the floppy seek even when there was no floppy inserted. The advice to fix that was to flush the list of places to check. I verified that worked in XP, but never did track down how it got that added to the list. Perhaps there is something similar in Win7 that has gotten paths to your external drives added to a similar sort of list. Maybe this description will give you a clue for something to find with a few well chosen searches.
harborsparrow
#7
Aug15-13, 08:43 PM
PF Gold
harborsparrow's Avatar
P: 347
I would also check to see if you have a swap file on one of the external drives. That would do it, if the action you did caused memory to have to swap in/out. Users can say where their swap file will be, and force it always to have a large size allocation (keeps disk from fragging so much), but that wouldn't change the need for the swap file to be used unless (perhaps) you keep fewer programs in memory at one time, or bump up RAM or cache sizes.


Register to reply

Related Discussions
External Hard Drive extremely slow. Computers 6
Turned my Laptop hard-drive for windows into a external hard drive, Computers 3
External hard drive issue Computers 4
External Hard Drive Computing & Technology 7
External hard drive Computing & Technology 7