Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Calculators Frozen TI-89

  1. Jun 17, 2010 #1
    Hi all,

    After about 15 weeks of no use (set theory course this term), my TI-89 is now completely unresponsive to any input. I have tried removing the batteries, holding down
    + [2nd] + [on], and [-] + [)] while reinstalling one battery as indicated in the owner's manual. I have also tried the "blow hard into the USB port" solution. None of these have worked for me. My problem is essentially the same as those outlined http://ti-89.org/forums/topic894-ti89-frozen-keys-ignoring-no-os-no-busy-no-reset.html" [Broken]. Any advice would be very welcome!

    Ad Astra!​
    Last edited by a moderator: May 4, 2017
  2. jcsd
  3. Jun 18, 2010 #2
    Have to tried removing the back-up battery?

    It is located under the little screw on lid in the battery compartment. Take this out and put it back in.
    If the screen doesn't turn off after you remove this the screen may have burned out. I haven't heard of this happening before, but I suppose it is possible.

    I don't know what blowing in the USB port is supposed to do.
  4. Jun 18, 2010 #3
    Ya, I've tried removing the back-up battery as well. The screen turns off, but when I re-install the batteries, the calculator resumes in its frozen state. To be clear, the screen does change in response to some inputs. For example, when I try the
    + [2nd] + [on] solution, it shows the appropriate "Installation in Progress. Do not turn off" screen, but then reverts to its frozen state. In this state it is completely unresponsive to (almost) any keyboard input. For example, hitting [2nd] + [on] does not turn it off, hitting enter when the cursor is over the home icon in the apps page (where it is currently stuck) does not take me to the home screen, etc.

    I am also unsure of the purpose of blowing on the USB port, but it was offered as a solution that allegedly worked for some, so I figured it was worth a try.​
  5. Jan 18, 2012 #4
    Hi, Sorry I know this post is nearly 2 years old, but I am having this exact same problem. I have the TI-89 Titanium. It is completely unresponsive at the main screen, however the only thing i can do is reset it.................

    ---Fixed--- Miraculously, my calculator is now working while I was in the process of posting my above message. After about 6 months of it not working, I decided to search for a post with a similar problem. Basically, after I reset it by holding [2nd] +
    + [on], it showed the screen: ---- "Installation in Progress. Do not turn off" ----, but it always returns to the APPS page, completely, "frozen."

    ---I have reset it several times, but with no luck. I then reset it one last time before I left it at the screen for about thirty minutes. At the time, my guess was that my batteries would have eventually died out if I left it on all night, but when I returned to it, I found it fully functional again.----

    Maybe someone else can explain what really fixed it. I don't know if having it reset soooo many times was the fix, or letting it sit, frozen, but
    I must say, Thank God! I was starting class next week too!​
  6. Jan 30, 2012 #5
    I have the EXACT same problem and am getting so frustrated. Every once in a while it will work for 5 mins, then the next time I try to use it it's frozen again. silenthitman... is yours still working??? Please someone help me out, I dont want to have to buy another
  7. Aug 26, 2012 #6
    I'm having the same problem. After 5+ weeks of no use it freezes and only works for a min if you blow compressed air into the i/o ports.

    right now i'm trying my heat trick. On past ti-89s when i had problems I realized that leaving it in the car for the day and having it heat up seemed to solve problems so i'm trying that now.
  8. Aug 26, 2012 #7
    Try removing all main batteries as well as the backup battery -- and leave it this way for at least 15 minutes (more if you want to be on the safe side).

    I had my TI-89 lock up once to where waiting, not just pulling all the batteries, was necessary.

    I hope this helps.
  9. Sep 26, 2012 #8
    Wow, it seems a lot of people are having issues. Some more information that might be helpful is:

    What kind of apps or programs do you have installed? (some games and utilities might be buggy or intended for older or newer hardware versions).

    Also, when it says Installation in progress, it can take several minutes to fully work. If you get to that screen, that is a good thing. If you still cannot get to a screen like that, you may need to reinstall your OS. For that, you will want to download the appropriate TI-Connect for your platform and download the latest OS for your model (these can be found on education.ti after a simple google search). This last method should solve most problems as very few people even know how to permanently brick their TI-89s.

    As to the advice about blowing into the USB, that usually should not be a problem. The only time the USB port is a problem is when you have either a conductive piece of metal stuck in there or dust that has gotten damp (this could also be a problem inside your calculator, though unlikely). You should also check the I/O (serial port) for this problem, too. There is what is known as a "silent link" mode on the TI-89 and other models and having an issue like this can cause it to seem to freeze.

    Finally, if the problem is in fact a combination of dust buildup and moisture inside the calculator, I suggest finding a way to dry it out. You can use silica packets, a bowl of rice, a bowl of salt (wrap your calc in a breathable fabric in all these case) or just take it to a dry environment.
  10. Sep 30, 2012 #9
    Sorry for the late reply. I got my calculator out of the car after a couple days and it worked perfectly again. The car acted as a makeshift reflow oven and took care of the bad connections that were causing the freezing to happen.

    So if anyone wants to try this, take the batteries out of the calc and stick it face down in your car for a couple days.
  11. Dec 13, 2012 #10
    So this happened to me, the screen was frozen and every time I reset it -> Left + right + 2nd + on all at the same time, it would go back to the frozen screen, but what you need to do is reset it and wait like 10 mins with calculator on and then it works again :)
Share this great discussion with others via Reddit, Google+, Twitter, or Facebook