Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Ubuntu 14.10 - Modifying .conf file

  1. Oct 26, 2014 #1
    Hi there

    I installed the latest version of Ubuntu (14.10) onto an old desktop, and am trying to make it connect to the Workgroup all other computers in the house are on.

    I installed Samba as per the instructions here - http://www.techrepublic.com/blog/linux-and-open-source/how-to-join-ubuntu-to-a-windows-workgroup/ - and found the file smb.conf in the directory /etc/samba. I opened the file in gedit, and modified the code. However when trying to save the file I get the message 'You do not have the permissions necessarily to save the file.'

    I close the file without saving, right click on the file and see what permissions I can edit. However they're all 'locked' with a note at the bottom of the screen 'You are not the owner, so you cannot change these permissions.' How can I edit smb.conf, save it and get Linux to join the Workgroup?

    NB: I'm logged in as the user I created during the installation of 14.10.

    Any help much appreciated
    Stevie
     
  2. jcsd
  3. Oct 26, 2014 #2

    Borek

    User Avatar

    Staff: Mentor

    Can't you log in as a root?
     
  4. Oct 26, 2014 #3
    Matterwave suggested running sudo gedit in the terminal, which did enable me to edit the file.

    However the following appeared in the terminal, and when I tried to restart the service and file this is what I got:
    I also tried sudo /etc/init.d.smb restart, but got 'command not found' also.
     
  5. Oct 26, 2014 #4
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Ubuntu 14.10 - Modifying .conf file
  1. Problem with Ubuntu (Replies: 6)

  2. Ubuntu vs Debian EE (Replies: 10)

Loading...