Ubuntu 14.10 - Modifying .conf file

  • Thread starter StevieTNZ
  • Start date
  • #1
1,474
388

Main Question or Discussion Point

Hi there

I installed the latest version of Ubuntu (14.10) onto an old desktop, and am trying to make it connect to the Workgroup all other computers in the house are on.

I installed Samba as per the instructions here - http://www.techrepublic.com/blog/linux-and-open-source/how-to-join-ubuntu-to-a-windows-workgroup/ - and found the file smb.conf in the directory /etc/samba. I opened the file in gedit, and modified the code. However when trying to save the file I get the message 'You do not have the permissions necessarily to save the file.'

I close the file without saving, right click on the file and see what permissions I can edit. However they're all 'locked' with a note at the bottom of the screen 'You are not the owner, so you cannot change these permissions.' How can I edit smb.conf, save it and get Linux to join the Workgroup?

NB: I'm logged in as the user I created during the installation of 14.10.

Any help much appreciated
Stevie
 

Answers and Replies

  • #2
Borek
Mentor
28,473
2,871
Can't you log in as a root?
 
  • #3
1,474
388
Matterwave suggested running sudo gedit in the terminal, which did enable me to edit the file.

However the following appeared in the terminal, and when I tried to restart the service and file this is what I got:
stevie@LinuxServer:~$ sudo gedit
[sudo] password for stevie:

(gedit:3634): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:eek:rg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:3634): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:eek:rg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:3634): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:eek:rg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:3634): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:eek:rg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
stevie@LinuxServer:~$ sudo service samba restart
samba: unrecognized service
stevie@LinuxServer:~$ sudo /etc/init.d/smbd restart
sudo: /etc/init.d/smbd: command not found
I also tried sudo /etc/init.d.smb restart, but got 'command not found' also.
 

Related Threads on Ubuntu 14.10 - Modifying .conf file

  • Last Post
Replies
17
Views
2K
  • Last Post
Replies
10
Views
967
  • Last Post
Replies
6
Views
2K
  • Last Post
Replies
6
Views
2K
Replies
5
Views
1K
  • Last Post
Replies
12
Views
27K
  • Last Post
Replies
13
Views
4K
  • Last Post
Replies
6
Views
5K
  • Last Post
Replies
5
Views
11K
Top