Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Unable to Transfer Data Over Ethernet

  1. Jul 23, 2015 #1
    Hello everyone,

    I am currently working on a project that was using an Ethernet extender which converted the signal to VDSL, sent it over approximately 300 feet of tether, converted it back to Ethernet which then communicated with a couple of IP sensors. The extenders are proving to be unreliable however.

    From my understanding, I only require 4 conductors for 10/100BaseT. I am trying to prove this concept before implementing it into the actual design. I have made two cables, which are using pins 1,2,3, and 6 on the RJ45 connectors.

    The setup I am trying to test right now is PC --> switch --> PC and trying to ping back and forth. I am unable to get any communication doing this.

    I have tried changing the speed settings on both of the PCs network adapters to be 100M.

    Any insights into why this isn't working would be greatly appreciated.

    Thanks!
     
  2. jcsd
  3. Jul 23, 2015 #2
    Have you tried switching the Ethernet to half-duplex?
     
  4. Jul 23, 2015 #3
    are the link lights lighting up? if not try splicing one of your cat 5 cables into a loopback, look on the internet for how.
     
  5. Jul 24, 2015 #4

    meBigGuy

    User Avatar
    Gold Member

    The VDSL extenders are being unreliable in what way? Hardware failing? Dropping packets? other? Whatever that issue is, you should probably determine the root cause before assuming that eliminating them will solve all your issues. (did you scrimp and buy unreliable extenders?)

    Have you tried your PC switch PC setup with standard cat5 cables. If that works, then there is something wrong with your cables.

    I suspect you are not using twisted pairs. (just guessing) 1 and 2 are twisted, and 3 and 6 are twisted.

    UTP ethernet is usable to ~300 feet I think
     
  6. Jul 24, 2015 #5
    Thank you for the replies.

    Yes I have tried switching the Ethernet to 100 Mb half and full duplex - no lights come on on the switch. I will try and splice one of the cables into a loopback and see what happens. I have tried this setup with normal Cat5 cables and everything works fine.

    The VDSL extenders are unreliable because every now and then they will drop communication for about 30 seconds - which is a big problem. They were working fine with one IP sensor, but when a second one got added there were a lot of problems with it - I think the data rate is too much for the extenders to manage on a single twisted pair. As far as the price of the extenders, they are pretty cheap (about $100). but since we are still within the range for Ethernet I want to see if I can get it working with 2 pairs, and if it works better, will just re-arrange some conductors in my tether.

    I have the software guy working with the two sensors and a switch using Ethernet right now and have not had any complaints right now.

    I think the problem may be with the cable also but not sure where the problem is. I have a box of a spool of Cat5 cable - I just cut off a length and spliced ONLY the 4 wires I needed (1,2,3, and 6) I used an ohmmeter to make sure that there is a connection.

    I am wondering if the problem is actually with the network cards of the PC? They are both rated for Gigabit. Would changing the speed they transfer change the protocol they use? If so that may explain why I am not seeing anything.
     
  7. Jul 24, 2015 #6
    So I made a loopback cable and when I plug it into the switch a light will turn on. I re-made the cable and took extra care to make sure that pins 1,2,3,and 6 are the only ones connected but when connecting a PC to the switch no lights will turn on - I'm thinking the problem is with the network card? Any settings I should change besides the speed?

    One thing I am seeing when looking at the network connection in the control panel is the LAN will become enabled briefly then go back to saying that the network cable is unplugged
     
  8. Jul 24, 2015 #7
    Okay so I've managed to get it to a point where I can plug the cables from the PC into the switch and see the lights turn on and start flashing as if they are transferring data. However, I am unable to ping between the two machines.
     
  9. Jul 24, 2015 #8
    what kind of network cards are you using, it my be a driver or software issue. you can plug more than one nic into your computer and see if you can transfer data between them, what does the arp table on your switch say, there is software like wire shark to examine ip.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Unable to Transfer Data Over Ethernet
  1. Data transfer problem (Replies: 5)

Loading...