Need admin privilages to install program, but I am admin

  1. I am attempting to install a program, but when I start the install a window pops up that says that I need administrator privileges to install the program. I am the admisistrator on my computer! What is the deal? I have tried creating a new account that is the admin, and installing it with that account and it says the same thing. I also have all of my antivirus, firewall, and antispyware software turned off when I am trying to install the software.
     
  2. jcsd
  3. -Job-

    -Job- 1,132
    Science Advisor

    Right-click on the installer file and select "Run as...". In the window that comes up the radio option that's selected should be CurrentUser(username). Is "username" an administrator? You can uncheck the option "Restrict this program with restricted access" or specify a different user.
     
  4. Unfortunately that did not work. Windows XP Home Edition is the OS I am using if that helps anyone help me better. And the program is like an interactive book. It is called "Kinetics Books: Physics for Engineers and Scientists".
    Man, I fell like I have tried everything that I know how to do. I even went into the key registry and altered that according to the fourth option on this website:
    http://pcsupport.about.com/od/quicktips/qt/addadmin.htm . I now have the option of signing on as the admin, but when I attempt to it says that I can't. I guess you can only sign on as the "true" admin in safe mode with XP Home Edition. So I have also tried to sign on with the admin account in safe mode and install the software then, but I get the same message: Administrator privilages required to install software. or something very similiar to that. Please help.
     
  5. Here is the message that pops up when I attempt to right click on the install file and run it under the "true" admin account: "Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy has been enforced." How do I bypass this? I am positive I am using the correct password because I went in and changed the password last night.
     
  6. I have read that I should put in my windows disk, and run the repair option by booting from the cd and selecting this option, but when I do that it asks me what I want to repair, then it only gives me one option which is:
    1) C:/Windows
    and it only gives me one space to put in an answer, so I put in 1 and press enter. Then it just pops up the C prompt and does nothing else. Am I supposed to tell it to do something else. Please help me people, I called Dell, and they are going to charge me $100!!! to help me fix the problem. That is just for phone support. Crazy huh?
    I called the company that makes the program, and I have been talking to them for about four days now, and they can't figure out what the problem is.
     
  7. robphy

    robphy 4,395
    Science Advisor
    Homework Helper
    Gold Member

    Did you try googling [key parts of] your error message?
    http://www.google.com/search?source...count+restriction.+Possible+reasons+are+blank
    (From browsing the results, it seems there are lots of attempted fixes for various situations... too numerous to report here. One them [sorry, can't remember which] suggested that there may be a security "policy" that prevents installation from a CD... maybe this applies to you.)
     
  8. -Job-

    -Job- 1,132
    Science Advisor

    Before anything, what environment are you in? Is this your personal computer or are in a computer that is, or used to be, part of a school/library/public network/computer lab?
     
  9. Home computer. I do not have a network set up; although I did have another computer networked to this one up until a few weeks ago. I just had a wireless router that this computer was connected to and I had a wi fi enabled laptop. But I gave the laptop and the router to my dad, and now this computer is just hooked up directly to the cable from the wall. I did not change any settings when I disabled the network; I simply unplugged the router and plugged this computer into the cable outlet directly.
    And there is only one account that I created on this computer, so by defualt it is set as an administrator account. But there is another account called "Administrator", and the only way I can log onto that account is to do it through safe mode. The account title "Administrator" was not created by me, it is the account that I think has ALL of the admin privileges. I can not run the file under the "Administrator" account through the run as command as advised earlier either.
    Do you guys know what I am talking about about there being two different types of administrator accounts?
     
  10. -Job-

    -Job- 1,132
    Science Advisor

    Can you do the following:
    . go to control panel -> administrative tools -> computer management
    . on the window that comes up udner "local users and groups" there should be a folder for users and a folder for groups
    . select the folder users, on the right side select your user, right click and select properties. Under the tab "member of" is there the group "administrators"? If not, add yourself to that group (you may need to be logged as admin if you're not admin).
    Which groups is the administrator account part of?

    Can you also post which groups there are in your computer other than administrators, or message me if you don't want to make that public?
     
  11. I can not do that for some reason. I have tried to do this many times because this is what most sites say to do. When I go to control panel -> administrative tools -> computer management there is not a folder named "Local users and groups". It should be under the system tools folder, but it is not there. I have even tried to log in on the account named "Administrator" through safe mode and that folder is still not there. I am not sure what the deal with that is.
    There is something that I would like to explain more clearly so you might be able to help me better. I only set up one account on this computer, and I named it and set it to have administrator privileges (actually it was set to admin prilileges through a default setting because there is not another account on the computer with limited privileges). So that is the only account that I have created that is currently on the computer. Now there is one more account on the computer though, and it is actually named "Administrator". I did not create this account. I can only log on with this account if I boot from safe mode. And I have tried to log onto that account in safe mode and install the software under that user, but I get the same message.
    Here is the exact message I am getting:
    "Administrator privileges are required. You do not have the Windows operating system pricileges required to install our software on this computer. Please contact the Administrator of this computer to help you with the installation. Note: The privileges associated with the Administrator will be able to install this software."

    And that is all. There is not an error message or anything. At the top of this window it pops up in it does say "Kinetic Books". Which is the program that I am trying to install. So it looks like this is a window that pops up from this software, not from windows itself. But I have been taling to the company for days, and they have no idea what the heck is wrong. They said they have only seen this once before, and they solved it by having the customer removing all of his peer to peer software, and then it installed. I have done this and it still won't install. I have also disabled my firewall and antivirus. If you can help me please do, I want to study with this for my physics final next week, but time is running out.
     
  12. Is it possible that I set up some kind of security setting when I ran the network setup wizard when I set up the network I used to have? Because like I said, I have not changed any settings since I took apart the network, i just unplugged the router. There is something in the Control Panel that I don' t know what it is, and it looks like it possibly could be linked to this problem. It is a program (or utilitie?) in the control panel called "BDE Administrator". I guess it is for running a network. Should I have this on my computer?
     
  13. -Job-

    -Job- 1,132
    Science Advisor

    If you go to control panel -> users the window that comes up shows the users in your computer. Can you select your user, click properties and check group membership?
     
  14. Yes, I am listed as Computer administrator under the name of my account. What is weird though is that now there is another account there that I have not seen before and I have not created it, it is called ASP.NET Machine A. And it is listed as a limited account.
     
  15. There is not a properties option there.
     
  16. -Job-

    -Job- 1,132
    Science Advisor

    Asp.net is the account used for the .net framework by a web server. What is odd about that is that you said you had Windowx XP Home edition, and the IIS web server only comes with Windows XP Professional (i think). Probably some of your other programs installed a IIS and the .net framework. What is the name of this router of yours?
    BDE is for Borland Database which i think is used by some peer to peer programs like Kazaa.
    Which network setup did you use? Was it Windows XP's network setup, or was it some app?
     
  17. -Job-

    -Job- 1,132
    Science Advisor

    Also, can you right-click on "my computer", select properties, then under the Computer Name tab your computer's name is displayed. What is the Full Computer Name. Is there a domain name specified? Usually when you setup a network with a domain, then a domain administrator is created.
     
  18. Yes, there is a computer name and a workgroup name. I don't know what you mean by domain name, but it doesn't say domain name anywhere. It does say computer description: Desktop.
     
  19. -Job-

    -Job- 1,132
    Science Advisor

    Ok, so your network doesn't have a domain. The problem is elsewhere. You are obviously the administrator, and it seems you can install other programs so it shouldn't be a policy thing, especially because you didn't do anything to change it. It seems it's the program that is conflicting with something in your system. What does this program do exactly, does it try to acces the web or anything?
     
  20. The only difference between home and prof xp, is that with home you cant join in with a M$ domain (active directory) and you dont have EFS.

    When you logon you are probabley using the welcome sceen. Disable it via users under control pannel. make sure that "fast user switching" and "use welcome screen" are unchecked. before you go further make sure you know your user logon, also your Administrator password. Reboot, then when you are prompted to log on log on with username = administrator and password = "your password"

    Then try installing the app..
     
  21. No it is not possible to logon to WINDOWS XP HOME EDITIONS with the "true" Aministrator password. It actually says this on microsofts website. You can only do so in safe mode. And yes job, it does appear as if the problem is with the program. The program does not try to get internet access. But even if it did, I have been disableing by firewall when I try the installs, so this should not be a problem.
     
Know someone interested in this topic? Share a link to this question via email, Google+, Twitter, or Facebook

Have something to add?