Upgraded to Windows 8.1, javac Not Longer Found

  • Java
  • Thread starter Cod
  • Start date
  • Tags
    nvidia
  • #1
Cod
324
4
I upgraded to Windows 8.1 Pro today and reinstalled all of my software. I'm having issues with the new Java JDK (v40). I can't compile anything on the command line. I keep getting the following error message:

javac is not recognized as an internal or external command

So I went back in and checked the Environmental Variables and everything is set correctly. When I check the PATH via the command prompt, I get the following:

C:\WINDOWS\system32>path
PATH=C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Clien
t\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:
\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:
\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\
Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Int
el(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Man
agement Engine Components\IPT;C:\Program Files (x86)\MATLAB\R2012a Student\bin;C
:\Program Files\Condusiv Technologies\ExpressCache\;C:\Program Files\Java\jdk1.
7.0_40\bin;


I triple checked and everything is using the correct path. I even reinstalled the JDK and get the same error.

Any thoughts?
 

Answers and Replies

  • #2
36,191
8,173
It looks to me like there's an extra space in your path, right after jdk1. and before 7.0 etc. If that doesn't fix things, I would make sure that the java compiler is in that directory, and not, say, in Program Files (x86).
 
  • #3
Cod
324
4
The space wasn't "really there". Just how it pasted after copying the command line. Turns out I finally got it working. I completely re-downloaded and installed the JDK and everything worked fine (didn't even have to change the variables). Apparently the first download was corrupted somehow.

Thanks for the help though.
 

Suggested for: Upgraded to Windows 8.1, javac Not Longer Found

  • Last Post
Replies
1
Views
2K
  • Last Post
Replies
1
Views
14K
Replies
4
Views
4K
  • Last Post
Replies
1
Views
769
Replies
19
Views
2K
  • Last Post
Replies
3
Views
3K
Replies
2
Views
305
Replies
8
Views
7K
Replies
1
Views
1K
  • Last Post
Replies
11
Views
4K
Top