Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Wireless networking and web access

  1. Jan 4, 2006 #1


    User Avatar
    Gold Member

    I have a laptop and a desktop, both with XP. They are connected via Linksys Wireless AccessPoint (Actually, the desktop is wired but I have a wireless card for it too). Both access the internet via DSL modem hooked up to the access point.

    What I can't do is get them to see each other on the network. This seems to be by design - some vulnerability issue. It will not LET me configure it so that they see each other as well as both see the internet.

    Now, as I understand, I could set it up so that they both access the intenet and see each other - by setting up the desktop as a server, and let my laptop access the web through it, but that means that the desktop MUST be on in order for me to use the laptop. I don't like that solution.

    Is it possible to set up my network so that:
    - my computers can see each other
    - they can both access the internet without having to leave one on all the time
    - my network is still secure
  2. jcsd
  3. Jan 4, 2006 #2


    User Avatar
    Gold Member

    That's odd... as long as they are all in the same workgroup, they should be able to see eachother...
  4. Jan 4, 2006 #3
    file server?

    Are you wanting to simply share files or is there a game involved? If you're wanting to share files, you could set up a free (yes, they do exist on windoze) ftp server on both of them and use explorer for the ftp access. So long as you don't open the ftp port on the WAP it should be relatively secure.

    As an aside, if you haven't enabled any form of encryption on the router, then you might as well consider it insecure even without clear-text ftp.

    FYI, I too have had this problem with Windoze file-sharing and networking, and I was so disgusted by it that I resorted to using a linux box stuffed into the small part of a desk as an ftp server. It's been running for about a month continuously now (hard some problems at one point totally out of my control).

    I don't know any quick and dirty way to really allieviate your problem within windows if you really want to stay away from ftp server software. I'll do some looking though.
  5. Jan 4, 2006 #4
  6. Jan 4, 2006 #5


    User Avatar
    Gold Member

    Yes to 1, no to 2.

    So, even though I have state-of-the-art network, I can't ... network?

    I have enabled encryption. (But only recently. Would that change my ability to network?)

    Again I ask: state-of-the-art network hardware and I can't simply network?
  7. Jan 4, 2006 #6
    :rofl: Believe it or not, this crap is the norm for M$. If you leave your security vulnerabilities up, you're liable, and if you close them, you make networking a nightmare!

    And now you know why I switched to a linux desktop. I might be forced to use ndiswrapper to run my wireless card, but I can see everything on the network if I want to. Of course it's not windows' fault per se, but maybe something to do with how the drivers have been written. Or the Windows filesharing protocol. Mine does the same thing under Windows, but Debian w/ samba doesn't seem to notice.

    As per the article linked above: http://www.winplanet.com/article/2544-.htm
    I haven't tried this, and I don't know if you'll want the hassle of assigning static ip addresses, but if you want to use workgroup networking under Windows, then this is the route to go (no pun intended).

    And yes, workgroups should work on XP pro, if you're wondering.

    NOTE: I've had similar problems in the past between WIRED computers. In fact, I'd have to say that I HATE workgroup networking. However, even if you do have XP pro on both, I don't think you'd want the insanity of setting up a client-server model to share a few files. I only bring up the ftp servers because I've had success in the past with them. They don't use the windows filesharing protocol and thus don't rely on windows to see them (you simply use the ips). In fact, in most cases you can look the ipaddresses up on the routers client table. Then all you have to do is ftp into the server (something like Either way, these solutions would allow you to access the internet and have filesharing without setting one up as a gateway.

    Good luck.
  8. Jan 4, 2006 #7


    User Avatar
    Science Advisor

    Notice that even if a computer does not show up it doesn't mean it's inaccessible. I would assign static IPs, make sure you disable any firewalls (temporarily, just to see if this works), then on one of the machines, the desktop for example, share a couple of files/folders. On the laptop, go to start -> run -> and then type (lets pretend your desktop's IP is
    Just so you know, i have the exact same setup as yours. Me and my brother have computers on a wireless network, and i tried the above and it didn't work but i believe that was because i have ISA and my brother has some other firewall which i didn't feel like palying around with, so it may work for you.
    My solution, and this worked, was, as mentioned, to setup my computer as an FTP server. Of course i hate FTP and it usually requires an FTP client (IE's FTP capabilities are not the best). There's a simple way, which is to use WebDAV, which is secure and windows explorer supports it so you don't need any special software.
    In order to set it up you need to have IIS up and running, then you install the WebDAV capability onto it and share your folders.
    After this all you'd do is go to My Network Places and Add a Network Place by specifying the IP of the computer running WebDAV and that's it, real easy. :smile:
  9. Feb 1, 2006 #8
    I had a similar problem getting two XP computers to see each other. I created a network and both computers accessed the internet. One was wired and the other was wireless. I managed to fix it by adding the IP addresses being used in your access point/router to the firewall exceptions. You should be able to acces this just by going to windows help and typing firewall into the search window. Find out which IP address your router is assigning and just add those to the exceptions. It worked for my computers. Hope this helps.
  10. Feb 3, 2006 #9


    User Avatar
    Gold Member

    Doesn't it assign a different one every time it connects? Or are you talking about something different?
  11. Feb 3, 2006 #10
    If you log into your router's setup page, you should be able to find what addresses it's using. Say for example, if you have to log into your router using, then your router will assign all its ports, wired and wireless, a number based on this numbering system. Usually, the wired ports are the first in the series so for a 4 wired port router it will use,, and so on. it then starts numbering the wireless address. The router's setup page should list which ones are being used by your other computers. All you have to do is add these to the exceptions in the windows firewall and you're set. i'm using a belkin wireless router so i'm not sure if lynksis works the same, but i would bet that these things all pretty much work the same. I'm assuming you've done this but I'll ask just anyway, you never know. You did set up a network on each computer right?

    When i had this problem my computers all connected to the internet and they could see each other but they could not network together. i know your computers can't even see each other so i'm not sure if this will help but it doesn't hurt to try.

    I just read your original post and noticed that you only made reference to an access point. Is only an access point or is it also a router? If it's only an access point it will not allow you to connect to the internet with more than one computer at a time. I'm sure you've already considered this, but again i'm just covering all the bases. What is the model number of the access point?

    hope this helps.
    Last edited: Feb 3, 2006
  12. Feb 3, 2006 #11
    Just setup DHCP on your router, jot down the name of both your computers and uses this name to connect to each other. Because they sit both on your LAN there wont be any problems with the so called "firewall" on your wifi router.

    Make your shares on each computer you want to be accessed, and ensure you allow "Everyone" to connect.

    Now map a drive by doing the following at run \\nameofcomputer\nameofshare

    This will work as long as you have netbios/netbieu enabled which you will be default. Netbios is a broadcast technology and will find the other computer on your LAN

    Just for you information:

    DHCP doesnt work like that, it doesnt care where you come from as long as you hit the correct interface where dhcp is enabled. And it recieves a vaild DHCPreq packet asking for an IP address

    An access point wont let anything connect to the interenet unless there is a router present. An access point works at layer 2 of the osi model and can be compared to a wired switch
  13. Feb 3, 2006 #12
    That is conventionally true but

    you should to configure your ip rather than only let plug-n-play cable do its job
  14. Feb 5, 2006 #13


    User Avatar

    Staff: Mentor

    HP's wireless networking center.


    and http://www.linksys.com

    I upgraded the home network to include wireless access via a mixed router (Linksys, 4 cable ports + at least 2 wireless).

    I seems to working fine, except two problems.

    1.) After installing Norton Internet Security on one PC, it lost the ability to recognize the workgroup ( :grumpy: :mad: ), although one of the other PC's can 'see', it is not accessible on the work group. This seems to be a problem with WinXP-SP2 (?), in which there is some incompatibility with security settings that muckup Windows Networking.

    2) The cordless phone interrupts the wireless connection of at least on one PC. The cordless uses ~ 2.4 GHz comm frequency, which is close to the wireless router, so I still have to twiddle with the frequencies to see if I can eliminate the interference. :grumpy: :mad:
    Last edited: Feb 5, 2006
  15. Feb 7, 2006 #14

    I said setup DHCP on the router.. I wasnt telling anyone to use 169 IP address..
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Wireless networking and web access
  1. Wireless Network (Replies: 14)

  2. Wireless Network Issues (Replies: 21)