Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Connect my Canon MX922 printer to my new wireless router

  1. May 16, 2015 #1
    I just bought the Netgear AC1200 router, I followed the instruction of typing "routerlogin.net" in the address bar, logged in and created my password. and I got both my laptop connected wirelessly to the router.

    My issue is setting up the wireless connection to the Cannon MX922 all in one printer. I followed the instructions using the front panel of the printer.

    1) I pushed Manu and choose wireless setup.
    2) I made it search for available wireless access point and it found my NETGEAR04.
    3) I entered in the password using the front panel of the printer and the printer came back and said "connected to the access point".

    But I still cannot talk to the printer through wireless connection.

    I tried:
    1) Redo the procedure with no luck.
    2) I use the push button option by holding the WPS button of the wireless router and push OK on the printer. I tried holding the WPS button while the printer was searching AND I tried release the WPS button after pushing OK. Both times the printer came back and said it connected to the access point. But still not working.
    3) I connected the USB and updated the MS and XPS drivers to the printer and still not working.
    4) I even tried redo the setup using the password came with the router, it can't even connect. So I know I did it right in changing the password of the wireless access point. Besides I use the new password that I set to link with another laptop to prove I successfully changed the password.
    5) I unplugged the power cord of the printer to let it reset, then went through the procedure, still no luck.

    6) I type "routerlogin.net" on the address bar and look for what is connected onto the wireless router. I saw both my laptop and the desktop. But I don't see the cannon printer.


    7) I printed out the network connection of the Cannon printer. It claimed it is connected to NETGEAR04 which is the correct router.


    Based on this, I think the problem is with the router, the Cannon think it's connected. I don't know what to do anymore. Can anyone help?


    Thanks


    Alan



    BTW, I looked in cmd ipconfig, but is there any way to copy the screen into jpeg file or something? Ctrl C and V does not work.
     
  2. jcsd
  3. May 16, 2015 #2
  4. May 16, 2015 #3
    Thanks for the reply, I did down loaded and installed both the MP and XPS drivers from Cannon, it did not help. The printer was working with the last router that broke. It's only one year old.
     
  5. May 17, 2015 #4
    I thought the setup software did additional things, like setting "switches" in the computer?

    Good luck, have been there trying to get a pc to run properly.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Connect my Canon MX922 printer to my new wireless router
  1. Wireless router (Replies: 12)

  2. Wireless Router (Replies: 9)

Loading...