Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Can't get styles to work on the fist page of References - TeX

  1. Feb 28, 2013 #1
    Hi all,

    The references have about 10 pages, and I set them to be fancy, ie, footers, headers, page numbers etc... but this will only work from the second page on. The first page won't accept any other settings but LaTeX defaults.

    Does anyone know how to fix this?

    Any help will be very much appreciated.

    Thanks
     
  2. jcsd
  3. Feb 28, 2013 #2

    Hepth

    User Avatar
    Gold Member

    Without knowing what TeX install you're using, what article type, etc. theres no real way of knowing. But if this is a TeX of ONLY references, then perhaps its making the first page of the document your "title page" and automatically suppressing the footers/etc. So you need to figure out how to force page numbers/etc on a title page.

    http://tex.stackexchange.com/questions/68197/force-page-numbering-on-every-page

    might have some info on forcing pagetype.
     
  4. Feb 28, 2013 #3
    It's a thesis so I chose 'report':

    \documentclass[12pt,a4paper]{report}

    and this is the references settings:

    \bibliographystyle{ametsoc}
    \renewcommand{\bibname}{Referências}
    \bibliography{Referencias}%{lof}{\protect\thispagestyle{fancy}}
    \thispagestyle{fancy}

    and I'm using MikTeX on Windows 8.

    Very much appreciated.
     
  5. Feb 28, 2013 #4
    Like Hepth said, maybe you are observing that behavior BECAUSE the references document is a legal latex document and can be compiled in its own right...BUT, references are usually included into a main document...when you compile THAT document, the first page of the references document will not be the first page of the document and, thus, I think it will behave that way you seem to want it to.

    Does this make sense? Is that what you are doing/not-doing?
     
  6. Feb 28, 2013 #5
    To be honest, and with all due respect and my limited knowledge of LaTeX, I don't think this makes much sense! We should be able to do whatever we need. I, for instance, just can't figure out how to do this!

    Márcio
     
  7. Mar 1, 2013 #6
    Márcio:

    I hear you. The thing is that if you are coming from other word processors that make certain things seemingly easier to achieve, you certainly find that latex has a totally different paradigm and accompanying learning curve...but it is much more powerful, stable and scalable.

    Just keep in mind that Latex is not a word processor; latex and friends are a publishing tool-chain that at times can feel more like programming than writing...and you do have to compile to see the results.

    So, while some limited amount of venting is understandable, if you really want some help around here, you need to also do some experimentation, try alternatives in an attempt to achieve the same final results, etc., and provide feedback.

    So, here are some explicit question for which would be nice if you gave explicit answers:

    is the References document a legal, self-contain latex document that can be compiled on its own?

    or is it a bibliography file?

    are you planning to compile the References document, print it and THEN manually bind it after the Thesis document?

    Or

    are you planning to \include or \input the References document into the main Thesis document?

    Or

    are you planning to use a bibliography file that after using references from there along your Thesis document, at the end, you can request a References section listing all used references throughout your document?
     
  8. Mar 1, 2013 #7
    Yes, it is a thesis and I'm using a bibliography file (bibtex) like this:

    \bibliographystyle{ametsoc}
    \renewcommand{\bibname}{Referências}
    \bibliography{ref/Referencias}


    I noticed the same behaviour happens to the Appendix. The first page is set as default and the others accept my personalized settings (footer, header etc)

    Many thanks
     
  9. Mar 1, 2013 #8

    AlephZero

    User Avatar
    Science Advisor
    Homework Helper

    Most LxTeX document formats are designed so the first page of each chunk of the document (e.g. each chapter) has a different format. That usually makes sense, because you don't want the chapter heading duplicated as part of the page heading on the same page.

    That is usually built into the code of the \chapter or \section command, using \thispagestyle{...} to redefine the page style for the current page.

    The table of contents, bibliography, etc, usually use \chapter or \section to typeset their own headings, so they inherit the same behaviour.

    The best way to override this is redefine the "plain" page style to look the same as the other pages. See http://anorien.csc.warwick.ac.uk/mirrors/CTAN/macros/latex/contrib/fancyhdr/fancyhdr.pdf section 7 (on page 7)

    A crude brute force method is just to define "thispagestyle" to do nothing (and ignore the LaTeX Style Police trying to break down your door!!)

    Code (Text):

    \def\thispagestyle#1{}
     
     
  10. Mar 1, 2013 #9
    Holy cow, AlephZero! I can't thank you enough. You just hit the nail in the head with the \def command.

    Cheers

    Márcio
     
    Last edited: Mar 1, 2013
  11. Mar 1, 2013 #10
    Hi

    Do you know if there is a way of 'stopping' this command? Once you use it, all following pages get footers and headers etc.

    Very much appreciated
     
  12. Mar 1, 2013 #11
    figured out. thank you!
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Can't get styles to work on the fist page of References - TeX
  1. Latex styles? (Replies: 2)

Loading...