Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

ESC not working as intended, what am I doing wrong?

  1. Jan 27, 2014 #1
    So I got my 20A Electronic speed controller, decided to wire it up to a motor, soldered everything, plugged it in, and then decided to give it a little shock to see if it would come alive.

    Nope, all I got was sparks, indicating a short cirquit, and no reaction from the motor, it seems like it was not powering the motor at all but simply flowing in a closed cirquit,

    here is a picture of the whole deal.

    What am I doing wrong?
     

    Attached Files:

  2. jcsd
  3. Jan 27, 2014 #2
    Impossible to tell from that picture. I see a (disconnected) battery pack, some white thing with a number of leads sticking out of it, and a motor with a propeller. What are all of those leads? What is the white thing? It looks like the leads going into the motor might be bare and touching each other.
     
  4. Jan 27, 2014 #3
    The white thing is the electronic speed controller, I have tried with the leads not touching each others, that is not the problem.

    On the left we have a brushless-motor, with three "stages" connected to an electronic speed controller(white thingy), in the back of the electronic speed controller are 3 wires. 2 are red and black and those draw the power, the third connector is for extra power from the battery, for servos and such(unless it is suppost to go to ground& in that case it might be the problem). But it says the third wire is BEC some sort of extra battery power for servos, radio control and such.
     
  5. Jan 27, 2014 #4
    This might help.
     

    Attached Files:

  6. Jan 28, 2014 #5
    How did you know which of the motor leads connected to which of the controller leads?
    How did you know which of the leads were power from the battery? Did you just guess?
    Brushless motors are sometimes computer-controlled. It looks like your controller might want to be plugged into some kind of controller circuit - the "power for other purposes" connector looks like a low-current signal connector.
     
  7. Jan 28, 2014 #6
    Hey, I've found the problem and got it up and running perfectly

    You were right, that other purposes thingy is both for recieving signals and for giving low voltage too i think. When I connected it to a microcontroller and gave it the right signals it worked. It recieves signals such as, Arm the motor, turn on/off and you can even control the speed of the motor.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: ESC not working as intended, what am I doing wrong?
Loading...