Keyboard lockup

  • Thread starter mathman
  • Start date
  • #1
mathman
Science Advisor
7,741
406

Summary:

During typing (such as this) the keyboard locks. How to unlock?

Main Question or Discussion Point

While I am typing something fairly lengthy, occasionally a message pops up asking if I want to go into some mode, where I don't type. When I see it, my answer is always no However on occasion I am busy typing without looking at the screen. If this message pops up and I don't check no, it assumes a yes answer and locks the keyboard. How can I get the keyboard back? Whenever it happens, the only recourse I know about is do a restart, which is a nuisance.
 

Answers and Replies

  • #2
1,322
1,129
Which OS? Which mode does the popup mention?
 
  • #3
33,079
4,782
Which OS? Which mode does the popup mention?
In addition to the above, @mathman, what's the computer brand, and what application are you using when this happens?
 
  • #4
11,268
4,731
While this may not be the issue, does your keyboard have a built in trackpoint device or a touchpad on the side?

In the past, I've had odd issues with the placement of those features. Touching either one will magically move the editing cursor to some other spot on the screen and in effect messing up what you were typing.

In particular, I had a Lenovo laptop with the trackpoint at the nexus of keys T,Y,G,H and when I'd type a G my finger would lightly touch the trackpoint (like pressing a button on a mouse) and the cursor would move to the mouse pointer on screen.

In you case, could there be some connection to corners on your monitor. Macos has feature of hot corners where sliding the mouse to one of the four corners of your monitor will lock the screen or do some other action.

For windows there's a key combo: window key + L key to lock the keyboard

https://www.techwalla.com/articles/ways-to-lock-a-pc-keyboard
 
  • #5
7,969
4,651
I have had cases where finger fumbles made me do things like press CTRL several times in a row, or push a key then backspace repeated several times in a row. A popup appeared that asked if I want to use the virtual keyboard for disabled people.

It would be interesting to see the algorithm they use to examine keystrokes to determine when to show that popup unsolicited. It is mildly insulting to see it.
 
  • #6
1,322
1,129
In the past, I've had odd issues with the placement of those features. Touching either one will magically move the editing cursor to some other spot on the screen and in effect messing up what you were typing.
That's why when I work with an external mouse, I keep the touch pad off in my laptop.
 
  • #7
11,268
4,731
The thing was I didn’t even know the trackpoint acted as a button since the laptop had buttons for that purpose. I thought it was some glitch in the keyboard until I typed something remembered I hit the track point slightly and realized where the g letter went on the screen. Bingo, I found the specs for the track point and the button feature it had. I turned it off and no more problem,
 
  • #8
mathman
Science Advisor
7,741
406
The message: Do you want to turn on filter keys?
 
  • #9
1,322
1,129
The message: Do you want to turn on filter keys?
Filter keys is a feature which tells the keyboard to ignore repeated keystrokes. People with hand tremors might hit the same key again and again; this is where Filter Keys help. By default, Windows will show you an option to switch on Filter Keys if you keep the Shift button pressed for 8s.

To turn off the message, go to Settings --> Ease of Access --> Keyboard. Scroll down to find the filter keys options.

1577690310499.png


By default, Filter Keys should be off. To turn off the message, toggle the highlighted checkbox.

Another similar message might pop up telling you about Sticky Keys:

1577690712453.png


This is again an accessibility feature which triggers when you press Shift key 5 times.

The option to turn off that message is available in the same accessibility window as above:

1577690817630.png
 
  • #10
mathman
Science Advisor
7,741
406
What confuses me is if I don't say no the keyboard locks.
 
  • #11
1,322
1,129
What confuses me is if I don't say no the keyboard locks.
"Don't say no" - meaning you are clicking "yes"?
Understood. The "Yes" option is highlighted by default, so if you press the spacebar or the enter key, the feature switches on and the keyboard locks. Once you turn off the shortcut(s) to the feature(s), as I explained above, that option will no longer come.
 
Last edited:

Related Threads for: Keyboard lockup

  • Last Post
Replies
7
Views
1K
  • Last Post
Replies
1
Views
3K
  • Last Post
Replies
2
Views
2K
  • Last Post
Replies
6
Views
6K
  • Last Post
Replies
14
Views
2K
  • Last Post
Replies
3
Views
2K
  • Last Post
Replies
12
Views
5K
  • Last Post
Replies
1
Views
3K
Top