Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Latex and Mathtype

  1. Sep 25, 2008 #1
    Can somebody please explain to me how to get equations into a post? I've read a lot about a sigma symbol that opens some kind of latex thing, but I've not seen the sigma anywhere. I actually use Mathtype a lot (in Word) and it has the capability to translate to various flavors of latex - I'd really prefer to do it in Mathtype and paste it into a post, but if I need to learn another way I'm willing to do so - PF is great! Thanks for help on this - I really did search around before posting this.
     
  2. jcsd
  3. Sep 25, 2008 #2
    The LaTeX editor is the sigma symbol next to the TV (youtube) icon in the post editor.
     
  4. Sep 25, 2008 #3

    Gokul43201

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

  5. Sep 25, 2008 #4

    jtbell

    User Avatar

    Staff: Mentor

    Set your MathType preferences to export to LaTeX 2.09, and turn off "Include MathType data in translation." Then when you copy from MathType and paste into the PF message-editing window, you should get LaTeX code. I got "\[" before and "\]" after the equation; if you get them, too, delete them. Insert a [ tex ] tag before and a [ /tex ] tag after the equation (remove the spaces inside the brackets... I had to put them there so PF wouldn't interpret them as tags). That's how I did the equation below.

    [tex]
    \sqrt {a^2 + b^2 }
    [/tex]

    For most equations it's quicker for me to type the LaTeX by hand, but for complicated stuff I sometimes use MathType instead.
     
  6. Sep 26, 2008 #5
    You can avoid having to replace the delimiters (the [ tex ] for "\[" , [ /tex ] for "\]") by hand each time if you create your own MathType translator file.

    For that you would have to:
    1. Copy the file "LaTeX.tdl" from MathType's translators directory (in Windows, it is "C:\Program Files\MathType\Translators" by default). Let's say you call this copy "FPLatex.tdl"
    2. Edit this new FPLatex.tdl translator file, and in the line that starts with "eqn = " replace "\["with "[tex]"and "\]" with "[ /tex ]" (take out the spaces after and before the brackets.)
      It should look like this:
      eqn = "<StdStartCmt><EqnDataCmt>[ tex ]@n#@n[ /tex ]@n<StdEndCmt>";
      (again, without the spaces inside the square brackets)
    3. Select this translator instead of the LaTeX one for export in MathType.

    After doing the above (and you only need to do it once) when you copy an equation from MathType it will be ready for pasting in the forum message.
     
  7. Sep 27, 2008 #6

    jtbell

    User Avatar

    Staff: Mentor

    Thanks for the tip! Under Mac OS X, the *.tdl files are in Applications --> MathType 6 --> Translators. (or "MathType 5" or maybe something else depending on which version you're using)

    To get the new tdl file to appear as a new item in the Preferences --> Translators menu, you have to edit the first line of the new tdl file so it contains a unique description. I now have a PFLaTeX.tdl file that starts with

    It appears in my Translators menu as "PF LaTeX".

    [tex]
    - \frac{{\hbar ^2 }}{{2m}}\nabla ^2 \Psi + V\Psi = i\hbar \frac{{\partial \Psi }}{{\partial t}}
    [/tex]
     
  8. Sep 27, 2008 #7

    Redbelly98

    User Avatar
    Staff Emeritus
    Science Advisor
    Homework Helper

    If you're using the "Quick Reply" box to make a post, you'll need to click the "Go Advanced" button to see the special editing symbols. The Σ symbol appears on the far right end of all the symbols.

    There's also a limited number of math symbols that you can copy-and-paste into posts:
    https://www.physicsforums.com/blog.php?b=347
     
  9. Oct 11, 2008 #8
    Well, I'm back at this again. I've tried EduardoT's suggestion, I've checked the code carefully, I don't get any error messages on the translations, but this is what I get:
    $\sqrt {x^2 + y^2 } $
    which should be coming out as:
    [tex]\sqrt {x^2 + y^2} [/tex]
    Any thoughts on how I can fix this?

    Also, I don't have a sigma button on my message editor; I've attached a screenshot. Ayn help would be appreciated!
     
  10. Oct 11, 2008 #9
    only displayed in the technical forums
     
  11. Oct 11, 2008 #10
    Ahh . . . thanks Greg. That explains one issue!
     
  12. Oct 13, 2008 #11
    Check that the new translator you created has them in the rule for eqn, and make sure that you have this new translator selected when copying the equation in MathType.

    One thing I neglected, that jtbell metioned afterwards, is that you also want to modify the first line of the translator file, to read something like
    MathType Output Translator 1.0: "PF LaTeX", "LaTeX for Physics Forums"
    so that it shows in the translators pull down list as "PF LaTeX".

    To select a translator in MathType, go to Preferences -> Translators... menu, check "Translation to other language", select the translator from the drop-down list, and click OK.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Latex and Mathtype
  1. Latex test (Replies: 2)

  2. Facebook and Latex (Replies: 3)

  3. LaTeX incomplete (Replies: 2)

  4. Latex broken? (Replies: 2)

Loading...