Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Maple, Integration, Invaild Differential

  1. Apr 9, 2006 #1
    I want to use maple to check my homework problems, but I cant get it to integrate even a simple function. I keep getting the error : Error, Invalid differential. I have been looking thorought the help for quite some time, and dont see anything on what is and what isnt a valid differential.

    I tried to integrate a simple function, y^2 dy with the limits from 0 to 2, but it wont do it, its an invaild differential.

    Any clues as to whats going wrong or where I can read about what is and what isnt a valid differential?

  2. jcsd
  3. Apr 12, 2006 #2
    Well, I have spent many hours over the last few days reading in maple help, searching on the internet, and today I was in the maple lab and asked my teacher. Nothing. Apparently nobody knows what is a valid differential or how to make maple integrate without this "Error, Invalid Differential".:mad: The only thing I can assume is that there is a bug in the program that will be fixed with a patch later....
  4. Apr 12, 2006 #3


    User Avatar
    Science Advisor

  5. Apr 12, 2006 #4


    User Avatar
    Science Advisor
    Homework Helper



    What exactly were you inputing? I couldn't get "Error, Invalid differential" with the few variations of using dy that I tried.
  6. Apr 12, 2006 #5
    yes I can input it that way, and it works.

    I am trying to use the integral symbol in maple 10 where you can actually see the "long s" of the integral, becuase I want to check triple integrals that get complicated.

    I am inputing it exctally like this [tex]\int_{0}^{2} y^2 dy [/tex] I also try this with no space inbetween the differential and the expression. The only way I can get it to integrate is if I leave the "dx" that it comes with alone and integrate with respect to x. But sometimes I want to integrate with respect to otherthings.
  7. Apr 12, 2006 #6
    here is a screen shot. the third one that works uses a "dx" that comes with the integral. I notice that the "x" is a purple color unlike the other variables...

    somehow I need to tell it the black x or the black y is part of the differental

    Attached Files:

  8. Apr 13, 2006 #7


    User Avatar
    Science Advisor
    Homework Helper

    Attatchment is still pending approval so I can't see exactly what you're inputing.

    I only have maple 9 on hand, in 9 when you hit the definite integral pallette it puts in an "?" instead of a built in "x", so it is expecting user input. I guess that's changed in 10?

    In the meantime, you can use the other way and still graphically check your input before it calculates the integral-the "Int" command instead of "int" is inert (just the old command capitalized). It will convert "Int" into the usual graphical format, but not attempt to evaluate it.
  9. Apr 15, 2006 #8
    How do I get the attachment to work?

    I am still struggling with this, trying to get maple to integrate using the integrand graphic and would really like some help.

    Maybe there is a maple forum I could go to...?
  10. Apr 24, 2006 #9
    I don't know why you are getting that error. I use maple 10 and do not get that error.

    try entering it like this, and let me know what you get:

    click on the icon that looks like:
    [tex] \int_a^b f \,\,dx [/tex]

    the [itex] a [/itex] should be highlighted. Perform the following keyboard commands:

    Code (Text):

    Where "x" would mean press the x key.
    Where "6" would mean press SHIFT+ press the 6 key.

    That should work. Otherwise, let me know exactly what you are doing, so I can recreate the error.
  11. Apr 24, 2006 #10
    Here's another keyboard combination:

    type "int"
    press CTRL+SPACE
    press, down, down, down
    type 0
    press tab
    type 2
    press tab
    type y^2
    press tab
    press enter
  12. Apr 24, 2006 #11
    Thanks for your help, I was able to get it to work using your keystrokes. The way I was entering it was using the left right etc. arrow keys.

    I combined the arrow method and the tab method and found the misbehaving keystroke is putting the cursor in front of the "x" in the differential and hitting delete, then typing in "Y". It works if you tab to the differential, or highlight it then stroke a key to replace it, but not if you use the delete key. (even though it looks the same :rofl: )

    Thanks again:biggrin:
  13. Apr 25, 2006 #12
    P.S. The new interface is PIMP.
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Maple, Integration, Invaild Differential