Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Configuring soundcard in linux Redhat 9

  1. Dec 9, 2004 #1
    How can I configure my sound card in Linux Redhat 9? When I use sound configuring tool it says "sound card not detected"
    If any one can help me with instructions to follow, it will be of great help?

    Thanks for the help.
     
  2. jcsd
  3. Dec 9, 2004 #2

    dduardo

    User Avatar
    Staff Emeritus

    What soundcard are you using?
     
  4. Dec 10, 2004 #3
    I am using Intel Corp.|82801EB AC'97 Audio soundcard. When I become super user and do Setup --> sound configuration tool , it says "The Intel Corp.|82801EB AC'97 Audio is not supported. "
    So, what can I do then?

    Thanks for the help.
     
    Last edited: Dec 10, 2004
  5. Dec 10, 2004 #4
    Most likely this is an integrated sound card. Go to www.intel.com and search for drivers for your particular motherboard; the audio drivers will be there. If they don't have a RH9 driver, you can try other Linux drivers they may have, ie RH Enterprise or SuSE9 drivers.
     
  6. Dec 10, 2004 #5

    dduardo

    User Avatar
    Staff Emeritus

    I would try a knoppix cd and see if it can detect it correctly. I'm almost positve linux supports that audio card. RH9 is pretty old and may not include this relatively new chipset.
     
  7. Dec 11, 2004 #6
    You are right, zefram.

    It is a integrated soundcard. I have already tried going to intel site and downloaded the particular driver. But that also could not help. It detected the card but complained that driver is not supported. So, what can be done then?

    Thanks for the help.
     
  8. Dec 11, 2004 #7

    dduardo

    User Avatar
    Staff Emeritus

  9. Dec 15, 2004 #8
    Hi dduardo,
    thanks for the link. I followed your instruction , but then this is what it asked:


    Intel Motherboard ADI AC97 Audio Device Driver has been compiled
    Following are the list of driver that has been load :

    ALSA Base driver : Not Loaded
    OSS PCM Module : Not Loaded
    OSS Mixer Module : Not Loaded
    OSS Midi Module : Not Loaded


    Do you wish to continue to configure your audio device?



    When I said ' Yes' , it complained ' Do you have Alsa Utils installed? ' So, where can I find this?

    Thanks for the help
     
  10. Dec 15, 2004 #9
    Thanks, dduardo

    Even though it complained I could listen the sample sound. I don't know why ALSA Utils are required.

    Thanks, once again.
     
  11. Dec 15, 2004 #10

    dduardo

    User Avatar
    Staff Emeritus

  12. Dec 16, 2004 #11
    Thanks for the link dduardo
    What are these YUM?
     
  13. Dec 16, 2004 #12

    dduardo

    User Avatar
    Staff Emeritus

    yum is a program like apt-get (debian) or emerge (gentoo) that installs software for you and automagically resolves dependency problems by downloading and installing any additional packages you need. These tools make installing software in linux easier than in windows. I don't know how long you've been using linux, but there is thing called "dependancy hell" in which the software you want to install requires ten other programs, which themselves require ten other programs and you have to go and download and install the dependencies before you can install the program you want.
     
  14. Dec 17, 2004 #13
    dduardo,

    Hello!!

    I am new to Linux and learning to operate it. So, thanks for explaining. I followed your instructions but when I said "yum update" it took long time and the prompt command didnot appear. Does it takes so much time for updating.

    Do these yum's also satisfy motherboard specifications or the link you had given is
    sufficient?

    Thanks again for the help.
     
  15. Dec 17, 2004 #14

    dduardo

    User Avatar
    Staff Emeritus

    This site has better instructions:

    http://linux.lsu.edu/yum.php

    You'll actually need to place this file in your /etc folder:

    http://linux.lsu.edu/yum/redhat/9/yum.conf

    It basically has a list of all the servers you can download files from. Rerun "yum update" to get the lastest list of file, which can take some time.

    Yum is independent of which computer you have. If you get this file:

    http://linux.lsu.edu/yum/redhat/9/yum-2.0.5-1.noarch.rpm

    You'll see that is says noarch or no architecture. This means that it doesn't matter which computer you have, it willl install on anything that has redhat.
     
  16. Dec 20, 2004 #15
    Hi dduardo,

    When I did "yum update "
    After sometime this is what it showed:

    Gathering header information file(s) from server(s)
    Server: Red Hat Linux 9 - i386 - freshrpms
    retrygrab() failed for:
    http://ayo.freshrpms.net/redhat/9/i386/freshrpms/headers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://ayo.freshrpms.net/redhat/9/i386/freshrpms/headers/header.info
    [Errno 7] HTTP Error (CannotSendRequest):


    So what should be done then?


    Thanks for the help.
     
  17. Dec 20, 2004 #16
    Looks like a network connectivity problem to me. I can download the file just fine. Try again?
     
  18. Dec 22, 2004 #17
    You are right, zefram. There is some connectivity problem. I will try again.
    Thanks.
     
  19. Dec 22, 2004 #18
    Hi dduardo,

    I have done "yum update"
    But when I say " yum install alsa* "
    It says, there is no package found. So, what can be done?

    Thanks for the help.
     
  20. Dec 29, 2004 #19
  21. Jan 4, 2005 #20
    Wish You All "A VERY HAPPY NEW YEAR!!!"

    Thank you,Ramki, for your help.

    But I have already tried this. I think sound card is not compatible with RHL 9.
    If only help can be provided for how to check the compatiblity, it would be helpful.

    Thanks.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Configuring soundcard in linux Redhat 9
  1. Do I need a soundcard? (Replies: 1)

  2. NES soundcard hacking (Replies: 1)

Loading...