Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

TextPad Editor

  1. Jan 19, 2006 #1
    "TextPad" Editor

    I have a problem, and I hope that someone here will be knowledgeable enough to help me. I am trying to use "TextPad", a text editor that is especially designed for things such as languages. (My interest in this case is VHDL.) In any account, one of its features that I need is the ability to display various "keywords" in selected colors. (As I remember, an earlier version did this very well.) Unfortunately, I am having problems with this feature - - right from the start.

    I have tried everything that I could find in the Help files. I checked out the "Syntax Definition File" for VHDL, and it seems to be OK. I also went through the instructions for "customizing colors". I chose the item(s) (Keyword lists) that I wanted to display in color(s), and selected the colors. I also put a checkmark in the box that enables highlighting. The upshot is that I can now get any color of type for the selected keywords, as long as that color is black.

    What am I missing?

  2. jcsd
  3. Jan 19, 2006 #2


    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    Look under the Configure Menu -> Preferences -> Document Classes -> VHDL and make sure the "Files in class" list includes the filename extension you're using for VHDL.

    Did you use the "New Document Class" wizard to install your VHDL syntax definitions? I don't believe VHDL is included in the basic TextPad install.

    - Warren
  4. Jan 20, 2006 #3

    I didn't try to install a new VHDL definition file because the newest TextPad appears to have one. It does have the extension I am using. When I get In I will check with a couple of other file types and see if they present a similar problem. Then, if these work, I'll go back to the VHDL files.

  5. Jan 20, 2006 #4
    You were right! The VHDL Syntax file is present but was not recognized. That has been taken care of; thanks for the help.

Share this great discussion with others via Reddit, Google+, Twitter, or Facebook