Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Ubuntu 14.04, wireless network cannot connect

  1. Nov 19, 2014 #1
    I have recently installed ubuntu 14.04 alongside windows 7 but I'm having major issues with connecting to wireless networks.
    The networks are detected and show up in the network manager, but when I connect and insert the correct password (double checked), a window continues to pop up saying that I need to authenticate my password. I've searched for a solution online everywhere and tried everything.
    One solution worked ONCE, by turning on airplane mode and off again, but I've tried to do this again and it doesn't have the original effect.
    I use Ubuntu to computer program but do not have a very good knowledge of the technical side of the operating system.
    Can anybody help?
     
  2. jcsd
  3. Nov 19, 2014 #2

    Simon Bridge

    User Avatar
    Science Advisor
    Homework Helper
    Gold Member
    2016 Award

    Sounds like a server message - have you asked the sysadmin?
    Have you tried on other networks?
    What is the exact error message?
     
  4. Nov 19, 2014 #3
    Its my home laptop, so who is the sysadmin, me?
    I've tried on other networks at university and managed to get them to work, but when I'm at home it doesn't connect. The exact error message just asks me to re-enter my network password, but I know its correct.
     
  5. Nov 19, 2014 #4

    jedishrfu

    Staff: Mentor

    Have you ever connected to your home network with this computer and this version of ubuntu?
     
  6. Nov 19, 2014 #5
    yes, once. I managed to connect yesterday after restarting airplane mode, but after doing the same today that method didn't work.
     
  7. Nov 19, 2014 #6

    jedishrfu

    Staff: Mentor

    and when you connected you were able to browse some websites?

    I've had similar problems too and had to go thru a checklist of things:

    1) can the computer connect via wired connection and browse?

    if yes means the wireless in your home is the problem

    if no means the network to your home is the problem

    2) has the computer ever connected?

    if no means that maybe youve configured it wrong like using the wrong password or wrong wifi security setting

    if yes then maybe the computer is too far from the wifi box or its latched on to some other network wifi

    sometimes you can connect to the wifi but the network to your house is not working

    sometimes you need to power on reset the cable modem or wifi router...
     
  8. Nov 19, 2014 #7

    Simon Bridge

    User Avatar
    Science Advisor
    Homework Helper
    Gold Member
    2016 Award

    You are root on your own laptop, but who is the admin for your home network/router? It sounds to me like you are authenticated to the access point but there is another layer to go through.
    You should still go through jedishrfu's checklist.

    ... this is what leads me to suspect that it is not exactly Ubuntu that is the problem. Just checking: you were able to connect to your home network in the previous release without problems?

    ... write out the error message word-for-word and put it on it's own line please. Don't just paraphrase.

    Attempting to connect from the commandline usually reveals more information than the GUI dialogs.
    Have a read through:
    http://www.blackmoreops.com/2014/09/18/connect-to-wifi-network-from-command-line-in-linux/
    http://linhost.info/2008/12/ubuntuconnect-to-an-access-point-from-the-command-line/

    It can be firmware or something like that - Ubuntu devs seems to yoyo about how much they will support proprietary stuff by default in new installs. Have you seen:
    http://www.linux.org/threads/cannot-connect-to-wifi-at-home-after-upgrade-to-ubuntu-14-04.5873/ [Broken]
    http://askubuntu.com/questions/454325/cannot-connect-to-wifi-at-home-after-upgrade-to-ubuntu-14-04
     
    Last edited by a moderator: May 7, 2017
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Ubuntu 14.04, wireless network cannot connect
  1. Wireless Network (Replies: 14)

  2. Wireless Network Issues (Replies: 21)

Loading...