Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Arduino board works on one computer but not another

  1. Jul 14, 2011 #1
    Greetings,
    I have recently bought a roboduino http://store.curiousinventor.com/al...servo-ready-freeduino-arduino-compatible.html . I have tried uploading programs from my computer (a Dell Inspiron 1525 Vista) using Arduino 0022, however it does not seem to work. At first, I was getting the errors:
    avrdude: stk500_getsync(): not in sync: resp=0x00
    avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00
    After switching the board to Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega328, these errors stopped popping up.
    I was able to run a program that made a servo turn 90 degrees and it worked. I unplugged it and came back 10 minutes later only to find it stopped working.
    I have tried to re-upload my servo program, and tried a basic sample program (like the Blink test from this site http://arduino.cc/en/Tutorial/Blink) seem to program ok (since no errors pop up and the LEDs blink on the board), but after the board finishes programming nothing happens.
    I have tried to plug my roboduino (using the same USB cord) into a different computer and it works. It flashes the same way that it does on my Dell to signal that it is uploading, but after the sequence is over it runs the program.
    I do not think it is a power issue because I programed the roboduino on the other computer (an Asus), getting the program to run, and then plugging the microcontroller into my Dell (to use as the power supply) and it continued to run the program.
    I have also made sure that the programs are identical on both computers. I have checked that the data bits are the same and that the COM ports are as well.
    I have reinstalled the FTDI drivers on my Dell, and I have also updated the COM drivers.
    I think it must be a bug because I checked all the basic problems.
    Any help is appreciated.
    Thanks,
    programmer27
     
  2. jcsd
  3. Jul 14, 2011 #2

    MATLABdude

    User Avatar
    Science Advisor

    Do you properly unmount the USB cable prior to pulling it out? Some USB host ICs are very finicky in that regards. If not, did it work when you reset the computer?
     
  4. Jul 15, 2011 #3
    Yes I did, I did the same for both computers

    No it did not

    Thanks
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Arduino board works on one computer but not another
  1. Single board computer (Replies: 3)

Loading...