Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Can't Connect to Netburner PK70

  1. Jul 2, 2015 #1
    Hey guys,

    I am working with a couple Netburner PK70 controllers and can only access one of them via Ethernet, but the other one (which has been formatted by the previous person on this project) Can't seem to be accessed by any of the Netburner software, I am currently running Advanced IP Scanner to try to find it so that I can at least have a chance at accessing it, but it has been an hour and it still hasn't discovered anything...

    Do any of you have any experience with these embedded systems and have an idea of how I could access this one?

    Thanks!
     
  2. jcsd
  3. Jul 2, 2015 #2
    I haven't worked with these specific devices.
    But I have run into similar issues with other network attached devices (specifically Ethernet to serial convertors).

    Most of the brands I have worked with have a device detection tool. These tools do a broadcast for specific MAC address as opposed to IP addresses. The problem with IP scanners is if they aren't in your netmask it gets hard to find them.

    Depending on the operation of the device, you might be able to hook it and your computer up to a router, and then use WireShark to monitor the network traffic and see if you can't pick up the IP address that way.

    Or is there a way to reset the device back to factory default settings??

    These are all things I've had to do. Worst was when someone programed on to be ip 10.51.5.100 instead of 10.15.5.100 :D
     
  4. Jul 2, 2015 #3
    That sounds exactly like my problem. I have been using the detection software, but to no avail. I can pick up the working one just fine, so that is what has me concerned with this other one.

    I have been hooking it directly to my PC because I am working at a university and don't have direct access to the modem, though I guess I could hijack some of the Ethernet cords from the towers in the room to do that too.

    I have been looking in to resetting to factory spec, but I am worried that if it was formatted in a specific way for this project that I will loose all of that and have to figure it out from scratch.
     
  5. Jul 2, 2015 #4
    How have you been connecting it directly? With a serial port? Or via the ethernet port?
     
  6. Jul 2, 2015 #5
    Ethernet. I don't have a serial port unfortunately...
     
  7. Jul 2, 2015 #6
    So you could still try wireshark.
    Are both units the same model? It is possible that the one you can't locate needs a crossover cable, but that is pretty rare these days.
     
  8. Jul 2, 2015 #7
    They are both the same model, I really don't know what was done to it, but it is really frustrating
     
  9. Jul 2, 2015 #8
    Its always possible that its BORKED.
    This may be the case since the locator tool can pick up the one and not the other.
     
  10. Jul 2, 2015 #9
    What does "Borked" mean?
     
  11. Jul 3, 2015 #10
    Sorry its my Canadianese way of saying broken :)
     
  12. Jul 3, 2015 #11
    ohhhhh! well it only takes once and I won't have to be told again :oldsmile:
     
  13. Jul 5, 2015 #12

    meBigGuy

    User Avatar
    Gold Member

    What is the full product name? Are there any installed cards?

    I assume you have done all this:

    "To begin, you will need to find out the IP address of your module. There
    are several ways to do this. One option is to use the included utility IPSetup.
    If the device is powered on and plugged in to the same network as
    your PC, run IPSetup and all NetBurner devices on your network will be
    displayed with configuration options available.
    Another option to find the IP address of your device is to use the NBEclipse
    IDE. As before, ensure that your device is powered on and plugged
    in to the same network as your PC. Open NBEclipse, and in the bottom
    left of the workspace, NBFind can be found running. This will list the IP,
    application and MAC address of all NetBurner devices on your local network"

    Random thoughts:
    Is the ethernet light lit or blinking? (on the one that works? On the one that doesn't work?)
    Did you pull the sd card?
    Try the mtty app (see the deployment section here: http://www.netburner.com/products/network-product-kit/pk70-ex#download [Broken])
    Is there a hidden reset button underneath?
    Try switching power supplies. Maybe one is marginal.
     
    Last edited by a moderator: May 7, 2017
  14. Jul 6, 2015 #13
    The only thing that I had not tried is removing the SD card, I just tried it and didn't change anything.
    I have looked for reset buttons, but if there is one, it is probably inside, I will have to go borrow a screw driver to check on that
    This unfortunately is the only power supply I have for these, and I doubt my professor will let me buy another on his budget.

    the unit is the NetBurner PK70 with 4-Port RS-485 Serial-to-Ethernet Option.
    There is a 1Gb SD card that it is supposed to be writing to, but everything else is all stock.
     
  15. Jul 6, 2015 #14

    meBigGuy

    User Avatar
    Gold Member

    From NetBurner PC Tools Reference Guide http://www.netburner.com/pk70-ex-1/development-kit-20/661-400-18/file [Broken]

    3.2.
    IPSetup Does Not Display Your NetBurner Device
    If IPSetup does not display your device it is for one of the following reasons:
    1.
    A firewall on your PC is blocking network port number 20034. Try temporarily disabling your firewall to see if this is the cause.
    2.
    The application in your device is not running. This can happen during development if you download an application that is crashing. Network communication is only possible if you have a running application. To recover from this situation use MTTTY and download a working application through the serial port using the “FLA” command.
    3.
    You are trying to talk to a device on the other side of a router. The PC and NetBurner device must be on the same LAN.

    That manual also expalins how to use the mttty application.
     
    Last edited by a moderator: May 7, 2017
  16. Jul 7, 2015 #15
    So based on what I am seeing on the documentation it looks like I have to have a serial port to make this work, unfortunately I don't have one. So I ordered a converter and it will be here on Monday. I will post if I have any issues once I get that all set up
     
  17. Jul 7, 2015 #16

    meBigGuy

    User Avatar
    Gold Member

    I think there is a stock serial port. But, I'm just guessing from the manual. You would be better off calling support.
     
  18. Jul 7, 2015 #17
    There is, but my computer doesn't have one, All I have is HDMI so I am getting an adapter to serial
     
  19. Jul 7, 2015 #18

    meBigGuy

    User Avatar
    Gold Member

    You will need it, since it is really easy to load and test a new program that "borks" the device.
     
  20. Jul 13, 2015 #19
    OKAY!!!! I finally connected (kinda) to the netburner, but it is throwing an error every two seconds that I am not sure if it is a connection error or a program error. This will take some debugging so I will probably post here as I work through this

    Edit: I missed the line that says "Access Error" soooo I will try to force it to upload the program that was given to me and we will see what happens
     

    Attached Files:

    Last edited: Jul 13, 2015
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Can't Connect to Netburner PK70
  1. Connected problem (Replies: 3)

  2. Linux connection (Replies: 2)

  3. Connecting emails (Replies: 1)

Loading...