Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

When I open a program the command prompt window opens only

  1. Jul 19, 2013 #1
    Hi all, I have just started to teach myself C and yesterday I did something awfully stupid.

    I wrote a source file, exexuted it and I didn't know why the cmd window only briefly appeared, I now know that the line 'system("pause") would of fixed this. Regardless, I went to my .exe created by my compiler and set it to open with cmd.exe. Of course this associated all programs with cmd, so when I run Chrome for example the command window opens and that's it, I know I could just type in the filepath to open it but I would just like to revert it to how it was.

    Also, system restore doesn't work so I can't take that route.

    Thanks for any help.
     
  2. jcsd
  3. Jul 20, 2013 #2

    DevilsAvocado

    User Avatar
    Gold Member

    Murphy's law rules.

    murphys-law.jpg

    The Command Prompt always pops up for non-windows applications, and if your program just execute and end, you will only see a brief appearance.

    Gosh, this shouldn’t be possible... what Windows version do you have?

    I can understand this. :smile:

    1. Make a backup of your entire system + data.

    2. Look for a computer that has exactly the same Windows version as yours (maybe your laptop, friend, etc).

    3. Make sure this computer has a recent backup for the entire system + data.

    4. Go to the Start Menu and click on Run... and type regedit and press [Enter].

    5. Press [Crtl+F] and type exefile and select Keys and Match whole string only and press [Enter].

    6. Make sure it says Computer\HKEY_CLASSES_ROOT\exefile in the Status Bar.

    7. Right-click on exefile in the tree in the right panel and select Export.

    8. Save the file as RestoreExeFile.reg (or any suitable name) to the Desktop (or any other place where you can find it easily).

    9. Copy the file to your computer and double-click on RestoreExeFile.reg and now your system should be restored.

    10. Reboot your computer and remember to be careful out there! :wink:



    Edit: I missed one thing.

    11. On your computer start regedit as in 4.

    12. Go to key HKEY_CLASSES_ROOT\.exe which is fairly easy to find (double-click HKEY_CLASSES_ROOT and scroll down).

    13. Click on key .exe and make sure the value of (Default) is exefile.

    14. If not, double-click on (Default) to change it.


    Done!
     
    Last edited: Jul 20, 2013
  4. Jul 22, 2013 #3
    Explained very well, thanks for the help!
     
  5. Jul 23, 2013 #4

    DevilsAvocado

    User Avatar
    Gold Member

    No worries. :wink:

    P.S: You could try to go directly from paragraph 1 to 11. If you’re lucky this will work.
     
  6. Jul 29, 2013 #5

    harborsparrow

    User Avatar
    Gold Member

    It might be easier just to go into the Windows Explorer settings and dig down and change the default behavior for different file extensions.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: When I open a program the command prompt window opens only
  1. MS-PROMPT commands (Replies: 10)

Loading...