Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Slackware Partitioning Problem

  1. Jan 21, 2005 #1
    I'm trying to install slackware 10.0 on my computer, as a 3rd OS, with WinXP, and Fedora Core 3 already installed.

    I download the isos, check the md5s, they match. I boot from the slackware disc, and from then on its nothing but problems. For some reason fdisk will not access my hard disk to format it. I quit out, run fdisk in fedora to format the "unallocated space" as a linux partition. It works fine. I reboot on the slackware install disk. It tells me there is no swap space (there is since i'm already running fedora), and it tells me there are no linux partitions detected (there are 4 linux partitions, 1 boot, 1 root, 1 home and 1 blank that i'm trying to install slackware to.

    my hard drive is at /dev/sda but it tells me its unable to access it. Again, fdisk under fedora had no problem pulling it up.

    I'm completely stuck as to what to do. ANy ideas?

    Also: running cfdisk just brings up a fatal error.
  2. jcsd
  3. Jan 21, 2005 #2
    Last edited: Jan 21, 2005
  4. Jan 21, 2005 #3

    I don't get the funny....

    At any rate i'm dowloading the SATA iso, hopefully that will work.

    I actually don't have a floppy drive (haven't used a flppy in years, didn't expect to suddenly need one)
  5. Jan 21, 2005 #4


    User Avatar
    Gold Member

    It sounds like Slackware isn't seeing your IDE controller. This is pretty common if you have a Promise, Adaptec, etc.

    As suggested, try booting the 2.6.x kernel and see what happens. Perhaps the Slackware developers decided to compile in support for your IDE controller.
  6. Jan 21, 2005 #5
    well the sata.i did nothing to fix the problem.

    how do i run the install with 2.6.x? i can't find anything on how to do this.
  7. Jan 21, 2005 #6

    those boot disks are all kernel 2.4, is there actually anyway to boot 2.6 to install from? as far as i've found there is not. I can't even find a similar case of this problem anywhere.
  8. Jan 22, 2005 #7
    do u have an old PATA hard drive?

    You could always do an install onto that, compile a brand new 2.6.10 on it, then copy everything over to the SATA once it's setup? =o
  9. Jan 23, 2005 #8
    NO i only have the SATA hard drive. i tried to set it to "legacy ATA" but i could not find any place in BIOS options to set that.
  10. Jan 23, 2005 #9
    checkout this thread.

    I think the 2.6.7 kernel is in the testing directory on CD2. can you specifiy it during install ?

Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?

Similar Discussions: Slackware Partitioning Problem
  1. Slackware for college (Replies: 5)

  2. Disk partitioning (Replies: 4)