Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Superscript 2

  1. May 14, 2006 #1

    AKG

    User Avatar
    Science Advisor
    Homework Helper

    When using Internet Explorer, I could type in Alt+0178 (i.e. hold down the 'Alt' key and type in the numbers 0,1,7,8) and it would make a supersript number 2, and I would put these into posts. Now using Firefox, I can't do that here. I can actually still do it at another forum, and can type it into the address bar, it just doesn't seem to work when posting on this site. Any idea why it doesn't work here? By the way, when I do it, I hold Alt, and when I press 0, nothing happens (as usual), but as soon as I press 1, the browser seems to navigate to the PF index page.
     
  2. jcsd
  3. Jun 3, 2006 #2

    Ouabache

    User Avatar
    Science Advisor
    Homework Helper

    I don't know the answer to your specific query, however if your goal is to create a superscript on PF, you can use the LaTeX feature. example [itex]x^2[/itex]
     
  4. Jun 3, 2006 #3

    Hootenanny

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    You can also use the tags [ sup ] [ \sup ] (without the spaces) to create superscript lettering. The tags [ sub ] [ \sub ] can be used for subscripts.

    ~H
     
  5. Jun 3, 2006 #4

    Ouabache

    User Avatar
    Science Advisor
    Homework Helper

    That's great Hoot!! I had forgot there are lots of HTML formatting tags we can employ to change the presentation of our text. Following this link for some examples.
     
  6. Jun 3, 2006 #5

    AKG

    User Avatar
    Science Advisor
    Homework Helper

    I use the "sup", "sub", "itex" and "tex" tags all the time, but none of them are nearly as convenient as Alt+1078 for a superscript 2 (or Alt+0179 for superscript 3). I've tried to see what happens when I go on other forums and other webpages in general, trying it with both Firefox and Explorer. Explorer never gives any problems, and Firefox works fine on regular webpages and non-vBulletin forums. On another vBulletin forum, however, the same problems happened. Alt+1 seems to make me go back a page (or something like that) which is a problem because when I type in Alt+0178, then when I get to Alt+01 it acts like Alt+1 and sends me back. Alt+5 opens up the donation form here, and it opens up the FAQ on the vBulletin page (i.e. the vBulletin forum on the vBulletin webpage).

    I guess it's something vBulletin built into their software to make navigation "easier" for Firefox users, but it ended up just being annoying.

    Digging around a little, I see it is a problem known to the Mozilla community: Bug 257478. The guy it was assigned to is back on June 5, so maybe I and anyone else who's bothered by this will just have to wait a little.
     
  7. Jun 3, 2006 #6

    AKG

    User Avatar
    Science Advisor
    Homework Helper

    On vBulletin's support site, I found this. It was actually from that page that I found the Mozilla link I gave in the previous post. Anyways, the guy in this link says that there are some settings in vBulletin and in Firefox that can allow individual users to fix this problem for themselves. Does anyone know how this can be changed in vBulletin? I.e. if I can do it myself, can someone tell me how? If it is something the administrators would have to do, could they please do it? And does anybody know enough about Firefox and "about:config" to tell me how to fix this using that? Thanks.
     
  8. Jun 4, 2006 #7

    Gokul43201

    User Avatar
    Staff Emeritus
    Science Advisor
    Gold Member

    "²³" - using ALT keys on Firefox 1.0 in Win XP.

    This is the first time though, that this has worked for me. Previously, I've had the problem described by AKG - it would take me to the main page. I can't imagine what's changed now.

    Edit : Just discovered one little clue. ALT+1 is a shortcut key for the main page only when the "1" key above Q is used. This doesn't happen for me when I use the number keys in the box under NumLock.
     
    Last edited: Jun 4, 2006
  9. Jun 4, 2006 #8

    AKG

    User Avatar
    Science Advisor
    Homework Helper

    I only use the Numpad, i.e. the number keys in the box under NumLock, but I always get this problem. In one of the links I gave, it was suggested that you could turn off NumLock, but then it was later acknolwedged that this doesn't solve the problem ("Alt+1" is no longer a problem but "Alt+other numbers still are, e.g. 7 which is needed for Alt+0178") and it is inconvenient anyways.
     
  10. Jun 5, 2006 #9

    honestrosewater

    User Avatar
    Gold Member

    I'll keep an eye out for a way around accesskeys. In the meantime, why not use (X)HTML character references? Superscript two and three are U+00B2 and U+00B3, respectively; the other superscripts and subscripts are U+2070-209F. For decimal references, you use "", where N = 178 for superscript two (rendered: ²) or N = 179 for superscript three (rendered: ³). That's only 1 extra keystroke. Good? No good?

    Oh, woops, that's actually 2 extra keystrokes since you probably need SHIFT for "&#". Meh.
     
    Last edited: Jun 5, 2006
  11. Jun 5, 2006 #10

    honestrosewater

    User Avatar
    Gold Member

    Okay, to disable accesskeys in Firefox completely (I've already tested this myself -- it worked):

    1. Open Firefox.
    2. Type "about:config" into the location bar and press ENTER. A list should appear in the viewport.
    3. Locate the entry "accessibility.accesskeycauseactivation". It's the very first entry on mine.
    4. Right-click on "accessibility.accesskeycauseactivation" and select "Toggle" from this menu.
    This should change the default 'true' value to 'false', disabling accesskeys.
    *5. To (re)enable accesskeys, repeat 1-4.

    Voilà!
     
  12. Jun 5, 2006 #11

    AKG

    User Avatar
    Science Advisor
    Homework Helper

    Thanks honestrosewater

    "" is an improvment from "[ sup ]2[ / sup ]", I think. I'll have to wait until I actually have to use it in a post to see. I was hoping someone would know how to use about:config, and was excited to see you had posted what to do. But I did it and it doesn't work. Oddly, different things are happening now. Normally, I would start typing in Alt+0178 and as soon as I hit the "1", it would navigate me to the PF home page, I think. Now, it scrolls me up the current page I'm viewing, and highlights the link at the top to the PF homepage, but just doesn't direct me there. I mentioned earlier that Alt+5 would take me to the donation page. Now, it scrolls me up to the top and highlights the link to the donation page (the link that says "Upgrade") but again, doesn't actually navigate me there. Is there another configuration I have to toggle off?
     
    Last edited: Jun 5, 2006
  13. Jun 5, 2006 #12

    honestrosewater

    User Avatar
    Gold Member

    Sorry, I wish I knew. I tried it again with all of the digits, in and out of the text box, and it did some really funky stuff. Out of the text box, Alt+1 did as you described, but the rest were fine. In the text box, whatever I enter (e.g., Alt+0178) ends up opening Find -- where the characters are rendered correctly. I don't know what's going on.
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook

Have something to add?



Similar Discussions: Superscript 2
  1. 2 general questions (Replies: 3)

  2. To the man part 2 (Replies: 17)

Loading...