Dismiss Notice
Join Physics Forums Today!
The friendliest, high quality science and math community on the planet! Everyone who loves science is here!

Radio controlled Electromagnet: help needed!

  1. Aug 4, 2012 #1
    Hello everyone!

    Recently, I decided to start building my own home-made projects, starting at a small scale level. The first task I gave myself was to create an electromagnet. In a few minutes... done; beautiful. Easy as eating cake. However, I wanted to (just for the heck of it) make it turn on and off at a distance, so I started reading up on remote control, radio, microchips, electric motors, and all kinds of other things. I eventually went with trying to create a radio-controlled electromagnet.

    Realizing that finding parts to create a radio control system was a pain, I decided to buy a radio-control car, and use salvaged parts from there. I managed to get the microchip out of there, and remove it from the dual electric motors that it was attached to (successfully removed it with the wires still intact). Then I attached the microchip to a dual D-battery set up, which when tested with an amp meter (while using one of the radio-control joysticks) worked amazingly well. So everything was done good and fine, and everything worked well. I double tested everything I could think of, in every possible way I could think of.
    However, when I put the electromagnet into the circuit, and used the RC joystick, everything wasn't so jolly. The electro-magnet didn't work, and worst of all, the amp meter wasn't even picking up anything in terms of current!

    Basically, all I did was attach the ends of the looped wire (that is on the electromagnet) to the wires of the microchip (that used to be attached to one of the electric motors). And theoretically, in my mind, it should of worked, but in reality, nothing happens. I've just been rattling my brain about what could be causing this not to work!

    And I've tried everything, from switching wires, to trying different joysticks and testing both at the same time, in every way possible. I even tried adding a resistor in between one of the EMC wires and microchip wires: nothing. I tried wiring and rewiring everything. And I tested everything again, many times; everything works perfectly. I mean, the microchip is receiving the RC commands, and is sending current to the right place, it's just that something happens to the current, and then the electromagnet just doesn't work!

    I really have tried everything I could think of; if anyone could help me out here (maybe I missed something, or maybe my concept is off), then I would be truly grateful.

    Thank you for reading,
    - Curious_Dude
     
  2. jcsd
  3. Aug 6, 2012 #2
    anyone? I mean the least someone could do is tell me if it's even possible to build a radio controlled electromagnet, using that configuration.
     
  4. Aug 6, 2012 #3
    I don't know how you expect people to be able to help you if you don't post a clear description of what your problem is.
    This isn't helpful. What circuit? In what configuration? Diagrams!

    And what microchip? There are more than one out there. What model?
     
  5. Aug 6, 2012 #4
    Hello, milesyoung!

    Thank you for replying. You're absolutely right. It's my fault that I didn't think of including one, because it seemed to me like a simple question that deserved a simple answer...my bad... I was wrong, so I created a diagram. Forgive me for it being so crude, but I think it gets the point through.

    http://imageshack.us/f/16/diagram1r.png/

    Also, I just wanted to add:
    - the microchip came from a kid's radio control model car that I bought and disassembled; the model of the car is: New Bright --> 4310AS

    -There are wires attached to each transistor that is mentioned (not drawn, but specifically mentioned in text) on the diagram. The wires come in pairs of blue and brown: one type of each on each set pair of transistors mentioned (ie: brown is attached to F/B, blue is attached C17; same with other transistor pair). I have no idea why brown and blue wires matter, but it might be useful for someone I guess....

    Thanks once again,
    -Curious_Dude

    Edit 8/6/12--> 9:20ish PM: Since, the image of the diagram is not working for some reason; here is a link (copy and paste into browser; sorry for inconvenience):

    http://imageshack.us/f/16/diagram1r.png/
     
  6. Aug 6, 2012 #5

    Averagesupernova

    User Avatar
    Science Advisor
    Gold Member

    How did you have the "amp meter" connected?
     
  7. Aug 7, 2012 #6
    Well to be honest, when I first posted this thread, I attached the "amp meter" to basically a closed circuit (attached it to wires that were already attached to other wires), so no wonder I was getting a no current reading. I guess I was just to tired to realize what I was doing at the time, and mistook my result as fact without noticing the fault in the test itself...

    However, I did a retest yesterday, in which the "amp meter" (which is actually a misnomer now that I think about it, since it measures resistance, current, etc, and not just amps) was connected in between one of the electromagnet wire ends and one of the microchip wires (open circuit). I also tried connecting it in different spots as well (ie: in between different microchip wires and the electromagnet wire).

    Same result every time: Although, now I'm getting a current reading, I'm still getting a large reading in terms of resistance. And again, still, the electromagnet does not work and is not giving off any type of electromagnetic properties (no magnetic field is being formed).

    I'm still baffled by this, so I still really could use someone's help...

    Thank you,
    - Curious_Dude
     
  8. Aug 7, 2012 #7

    Averagesupernova

    User Avatar
    Science Advisor
    Gold Member

    I don't think you have the know how to get this right. You are talking about hooking the "amp meter" up but you don't specifically say how you are doing it, or at least nothing that makes sense to me. You don't say what it is set to. Is it set to amps or volts or what? It makes a difference how it is hooked based on what you set your meter too. Also realize that if you hook your homemade electromagnet to where the motor was hooked to you have shorted out the output from the circuit board. There is a very good chance you have fried it. If you don't know how to hook a multimeter in circuit I am wondering if you know the difference between volts, amps, etc. Especially since you posted:
    Generally current IS amps. So you tell us, how much do you know?
     
  9. Aug 7, 2012 #8
    Woah! Hold on there.... I'm not trying to show off how much I do know or what not, I'm just trying to get this thing to work. I can't help it if some of the things I say come off as wrong; English is not my first language, so it's not always easy to communicate correctly...

    I came to this forum to get help to build that radio controlled electromagnet, not to get ridiculed and sent to hell because some of the things I say are not compliant with textbook vocabulary. You're right that current is generally measured in amps; I was just listing examples for your benefit. I'm sorry if I by accident, listed two of the same object...
    And, also if I am wrong about something or don't do something right, then tell me, teach me! I'm here to learn! And after I learn, I'm here to use that knowledge to build what I set out to create!

    Anyway, I have the Amp meter set on DCV (Direct current voltage) on the lowest scale (which happens to be 10) when testing for current. I do this because I'm testing specifically for battery power within the system, which is what my electromagnet is supposed to run on (in this case). Also I thought I was clear as to where I attach the multi-meter (amp meter); let me try using my diagram to explain one of my typical tests.

    Okay, so, imagine that I connect the electromagnet to one of the microchip wires (say the one that comes out of the "F/B" transistor), then I connect one of the multi-meter leds to the other end of the electromagnet; I then connect the other multi-meter led to the C17 transistor wire. Now that's all I'm doing. Of course I get a zero current reading because I have not sent any message to the microchip to receive. So then, I move the RC joystick up (to go forward), and suddenly the current jumps up. That indicates to me that the microchip is working and is sending the current, and that the transistor is not fried.

    However, what really boggles my mind is that if the current is getting to the screw with the loops of wire, why is not creating an electromagnet? You stated that I would be shorting out the microchip output by connecting those wires to the electromagnet; but here's what doesn't make sense: an electric motor is basically an electromagnet that is inside a field of magnetism, created by external magnets.

    I took apart the small electric motor that the RC car had; both of those microchip wires were connected to a cylinder of metal, which was touching loops of wire, wrapped around 3 spindles, all on one axis. In between the cylinder and axis (which was inside the cylinder), were two magnets strapped to the inner walls of the cylinder. The point is, the only difference between that and my electromagnet is that the electric motor has external magnets, while my electromagnet does not. And also that my contraption is using the basic idea of a Faraday electromagnet, while the electric motor is using Lorentz's law of torque, but that's besides the point. Hence, I still need help, haha.

    Thanks again for reading,
    - Curious_Dude
     
  10. Aug 7, 2012 #9
    You have your multimeter set to DC voltage. You're effectively putting a very large resistor in series with your electromagnet. There should be another option for current measurement in amps.

    If this wasn't just a typo, you need to read up a bit on basics. I can recommend:
    http://www.allaboutcircuits.com/
     
  11. Aug 7, 2012 #10

    Averagesupernova

    User Avatar
    Science Advisor
    Gold Member

    It seems my concerns are well placed. There is a very large difference between an actual working motor and a homemade electromagnet. Milesyoung is correct in that you have the meter wired in series which is used for current (actual amps, not volts) while the meter is set to volts. My recommendation is to check out the link that milesyoung posted and then start with something simpler like a small incandescent indicator bulb in place of the motor leaving your electromagnet out of it for a bit. Try some measurements using your meter with this setup and get used to using correctly.

    When I said generally current is amps I meant that at times people will say that they 'shut off the current' before they replace a residential light switch or cieling fixture or something. That is typically an accepted way of stating things although technically wrong, but current, actual current is ALWAYS measured in amps.

    Again, I suspect you are getting current and volts mixed up. A comparison would be if I asked you what the water pressure is at your meter and your answer was 10 gallons per minute or asked you how much water you were using at the moment and your answer was 40 PSI. I am sure you can see how those answers make no sense. Based on your posts I am not sure you realize what is going on. Nothing wrong with that, we're here to help.
     
  12. Aug 8, 2012 #11
    Sorry for the late reply. I don't always have time to respond/ work on home-made projects. Crazy jobs have crazy time-tables... Anyway, I appreciate your help guys, but I'm still "morbidly" confused...

    According to every website I've seen, every book that I've read, and even the wikipedia about electric motors: in terms of concept, an electric motor is an electromagnet on an axis of spin, in between external magnets. Therefore, concept wise, there is not much difference at all...

    But, I'm not ganna get into a whole dispute over this, I just want an answer as to why this electromagnet isn't working, and that's that...

    Anyway, I looked at the source milesyoung put up, and it was a good "refresher" in terms of what everything is/ what everything means, so thank you for that. But, I'm afraid I'm still confused... fore you see...I'm back to square one. Allow me to explain:

    I used the multi-meter again (after testing it on a electric bulb circuit like Averagesupernova suggested), and set it for 25 DCmA (Direct Current mini Amps), and did all my previous testing routines on the electromagnet circuit. Did the same for 250 DCmA. These were the only settings of amps available on the multi-meter. The arrow jumped up like nuts every time and only when I moved the joystick up/down. This indicates finally that the microchip transistor is fine, and not fried. However this also indicates that current is getting to the "electromagnet," and yet no magnetic field is being formed.

    At this point, I'm more frustrated than curious, and would like it if someone gave me a straight answer as to why this is not working, and what I could to make it work.

    Thanks once again,
    - Curious_Dude
     
  13. Aug 8, 2012 #12

    Averagesupernova

    User Avatar
    Science Advisor
    Gold Member

    Did you test with the bulb with the ammeter in series? If so could you get the bulb to light at the same time the meter jumped up? Before worrying about the electromagnet you should do this so you know if your meter is doing what it should and that you are doing what you should.
    -
    If you have dug deep enough concerning electric motors you should know that a motor develops a counter electromotive force, or CEMF. What this is kind of like is the motor acting like a generator while spinning in normal operation. What this means to you is that the current drawn by the motor is reduced when spinning under no load or light load compared to a locked rotor condition. With a plain old electromagnet this isn't possible is it. Hook an electromagnet up to a DC source and it will draw as much current as if you took the amount of wire and completely unwound it and hooked it up. In your case I am assuming it is very close to a short circuit. Hence my concern with frying the electronics from your remote control car. My recommendation to you is to learn about relay switches. The coil in a relay switch is in fact an electromagnet and you can use the relay to switch the magnet on and off the way you wish to after you have proven to yourself you fully understand what is going on. When you understand how to use the relay, use a separate battery for the electromagnet.
     
  14. Aug 10, 2012 #13
    Hello again!
    Sorry for the late post... didn't have time really to check the forums + how the relay-switch works until now-ish...

    Yes, I did. Everything checks out. The amp-meter seems to be working fine... Also, I never knew about CEMF, thank you for telling me! :approve:

    This is actually something similar to what I was thinking about a few days ago, in that I would have something turn on something else to turn the electromagnet on/off. Now, I know what that something else is: a relay switch. Anyway, it seems pretty simple to understand; however, here is my concern:

    You need something to get the the "relay-switch electromagnet" to work (so that it can pull on the armature, causing the spring to extend, and also to cause the secondary circuit to become complete). In my scenario, I see what your saying: put my electromagnet as the secondary circuit with a different battery. Only problem is: if I want this to be activated by the RC joystick, then where does the microchip go? The only logical place to put it would be in the first circuit, in between the battery and the "relay-switch electromagnet." But, then I'm back to square one but with a different electromagnet (So then what?).

    Unless there exists a RC relay switch with a controller already in the set, then I'm not 100% sure if this is going to work.

    Thank you once again,
    - Curious_Dude
     
  15. Aug 10, 2012 #14

    Averagesupernova

    User Avatar
    Science Advisor
    Gold Member

    I see you have not actually learned about relay switches. Look at the coil specs and compare the coil resistance with that of your homemade electromagnet. Ohms law will tell how much current a store bought relay will draw and you will most likely find that it is low enough for the RC circuit board to be able to drive. Do you really think I would have suggested you jump from one problem to one just as bad?
     
  16. Aug 10, 2012 #15
    "Learned" is a very broad term. When I learn quickly of things, I tend to learn concepts, not details about how much resistance/(or what have you) one single item has. You have to forgive me for not thinking about such things when I learn about objects, using "my method".

    Not at all. People who work, have other daily routines, or people who are just plain busy, can always make mistakes, especially if they have little time, and especially when posting on a forum. They can suggest things without even thinking about them, and that's totally fine. I'm not saying you did, nor am I saying that I would ever expect that from you. I'm just saying that anything is possible from anyone; so it's right to ask and double-check your "teacher." :smile:

    Anyway, I will try adding the relay-switch to my circuit, and see how it goes. If I have any more problems/ questions, I know where to go/ come back to get my answers.

    Thank you once again,
    - Curious_Dude
     
Know someone interested in this topic? Share this thread via Reddit, Google+, Twitter, or Facebook




Similar Discussions: Radio controlled Electromagnet: help needed!
Loading...